Official eMule-Board: 0.70a Unknown Error Popup - Official eMule-Board

Jump to content


Page 1 of 1

0.70a Unknown Error Popup

#1 User is offline   antonymous 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 17-March 08

Posted 28 October 2023 - 05:32 PM

Using 0.70a x64 on Win10, I'm getting a few "Unknown Error" messages popping up that want to be acknowledged about once a week. The only thing in the log reads like this:

28.10.2023 19:08:47: Unknown eDonkey Protocol Opcode: 0xb1, Size=0, Data=[ ]; Client=8656872@5.45.85.226 (211.229.156.150) 'www.EdonkeyP2P.com' (eMule v0.47c,None/None/None)
 


Looks like some hack/mod client sending an empty string, is that some kind of buffer attack?

This post has been edited by antonymous: 28 October 2023 - 06:47 PM

0

#2 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4969
  • Joined: 13-May 07

Posted 30 October 2023 - 09:21 AM

Unspecified error, you mean?
The log line is unrelated, or there would be no pop-up.
This is an unhandled exception; eMule keeps going and otherwise the issue was only annoying.
In my case the event is a lot less frequent and thus hard to know it the issue was fixed or not.

This message box should be possible to suppress, but it would be much better to know what cases the exception.
Possibly, you might help with testing of an updated build.
0

#3 User is offline   antonymous 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 17-March 08

Posted 30 October 2023 - 10:30 AM

Sure I can run a debug build. These plain popups are rare but I've seen it two or three times since updating to 0.70.
0

  • Member Options

Page 1 of 1

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users