Official eMule-Board: How I Solved My Kad Firewalled Problem - Official eMule-Board

Jump to content

Page 1 of 1

How I Solved My Kad Firewalled Problem

#1 User is offline   Zabadoh 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 14
  • Joined: 01-September 03

Posted 27 November 2022 - 02:42 AM

tl;dr I set my TCP and UDP to the same port number, checked the Use UPnP box, and restarted eMule.

I can't really explain how this fixed my KAD Firewalled problem.

So I can only describe what my situation was and what I did, in the hope that it can help someone.

Maybe a networking genius can explain what happened, and whether I've just made problems down the line for myself.

I'm running eMule v0.60d on Windows 10, going through a Archer C7 router to my ISP's modem.

Windows Firewall is turned off, as far as I can tell. Windows Defender is on.

My Connection setup was:

TCP Port: 61730
UDP Port: 56349

The "Use PNP To Set Up Ports" checkbox was checked

The UPnP page on my router's configuration told me that the above port settings were accepted by the router.

What eMule's Server tab showed was a HighID connection to any servers that I connected to, but KAD Firewalled, UDP Open.

I tried changing the TCP port number, setting up port forwarding on my router, with no success. KAD was still firewalled.

I was thinking that since the UDP port was "Open" and therefore wasn't having any problems, I should just use that too, so I changed my Connect ports to:

TCP Port: 56349
UDP Port: 56349

and restarted eMule.

After eMule came back up, the UPnP page said both UPnP settings were accepted as described, and eMule's Server tab said KAD was open.

So hooray!

A couple of experiments with random port numbers, also yielded KAD Open, as did the web page from the eMule Connection tab Test Ports button.

I hope this helps someone, even if I can't explain what went on myself.

This post has been edited by Zabadoh: 27 November 2022 - 02:53 AM


  • Member Options

Page 1 of 1

Fast Reply


1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users