Official eMule-Board: Running Emule In Windows 10 Pro Sandbox Firewall Problem. - Official eMule-Board

Jump to content


Page 1 of 1

Running Emule In Windows 10 Pro Sandbox Firewall Problem.

#1 User is offline   theoldfarter 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 30-January 07

Posted 17 October 2021 - 08:52 AM

Greetings.

I have never used Windows Sandbox, or any Sandbox program before so it is a learning curve for me.

I can run eMule v0.60c-Installer64 in normal Windows.

In normal Windows, during installation, I allow the eMule program in the popup Firewall box. Private network is ticked and Public is not ticked, by default.
I then tick "use UPnP to Setup Ports" in eMules setup and Windows Defender Firewall does its magic and says "UPnP successfully set up forwarding for ports 63898 (TCP) and 38908 (UDP)".

Then I click on the Test Ports button and the browser opens up and gives me 2 green ticks (TCP & UDP).
I also create an inbound and outbound rule in the Windows firewall, allowing connections. (every little bit helps).

eMule then runs fine and is seen on all of the eMule networks.

But, installing eMule into the Windows Sandbox is a different story.
During installation, I allow the eMule program in the popup Firewall box. Private network is NOT ticked and Public is TICKED, by default. I changed that around.

I then tick "use UPnP to Setup Ports" in eMules setup and Windows Defender Firewall does its magic but says "UPnP failed to setup port forwarding, please forward these ports if necessary."

Then I click on the Test Ports button and the browser opens up and gives me a red cross, saying:
"TCP connection test failed. It was not possible, to establish a TCP connection to your eMule.Other users will only be able to connect to you with the help of a server, resulting in a low ID for you. While eMule still works, this will give you several disadvantages. Therefore it is highly recommended to solve this problem."

I also create an inbound and outbound rule in the Windows firewall, allowing connections for eMule. Makes no difference. I then turned off Windows Defender Firewall. Made no difference.

I closed Sandbox which deleted everything. I opened Sandbox again, turned off Windows Defender Firewall & installed eMule. Made no difference, still get the "TCP connection test failed. It was not possible, to establish a TCP connection to your eMule."

Then I turned off the Firewall in both the Sandbox and Normal Windows, thinking that one of the Firewalls was the culprit in not allowing the TCP connection. It made no difference.

With the firewall on or off, eMule will connect to eD2K and Kad networks but the files showing from a search is small.
I need to get it connected properly.

What is the reason for the blockage of the TCP?

Seeing that TCP will not connect with the firewall on or off, leads me to think that the problem is not with the firewall, Possibly has something to do with Sandbox settings and the way it talks to my router. I have never "forwarded ports" before. Do not know how to do that but am willing to try. My modem/router is the Netcomm NF18ACV.

I would appreciate any suggestions.
0

#2 User is offline   theoldfarter 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 30-January 07

Posted 28 October 2021 - 04:17 AM

View Posttheoldfarter, on 17 October 2021 - 08:52 PM, said:

Greetings.

I have never used Windows Sandbox, or any Sandbox program before so it is a learning curve for me.

I can run eMule v0.60c-Installer64 in normal Windows.

In normal Windows, during installation, I allow the eMule program in the popup Firewall box. Private network is ticked and Public is not ticked, by default.
I then tick "use UPnP to Setup Ports" in eMules setup and Windows Defender Firewall does its magic and says "UPnP successfully set up forwarding for ports 63898 (TCP) and 38908 (UDP)".

Then I click on the Test Ports button and the browser opens up and gives me 2 green ticks (TCP & UDP).
I also create an inbound and outbound rule in the Windows firewall, allowing connections. (every little bit helps).

eMule then runs fine and is seen on all of the eMule networks.

But, installing eMule into the Windows Sandbox is a different story.
During installation, I allow the eMule program in the popup Firewall box. Private network is NOT ticked and Public is TICKED, by default. I changed that around.

I then tick "use UPnP to Setup Ports" in eMules setup and Windows Defender Firewall does its magic but says "UPnP failed to setup port forwarding, please forward these ports if necessary."

Then I click on the Test Ports button and the browser opens up and gives me a red cross, saying:
"TCP connection test failed. It was not possible, to establish a TCP connection to your eMule.Other users will only be able to connect to you with the help of a server, resulting in a low ID for you. While eMule still works, this will give you several disadvantages. Therefore it is highly recommended to solve this problem."

I also create an inbound and outbound rule in the Windows firewall, allowing connections for eMule. Makes no difference. I then turned off Windows Defender Firewall. Made no difference.

I closed Sandbox which deleted everything. I opened Sandbox again, turned off Windows Defender Firewall & installed eMule. Made no difference, still get the "TCP connection test failed. It was not possible, to establish a TCP connection to your eMule."

Then I turned off the Firewall in both the Sandbox and Normal Windows, thinking that one of the Firewalls was the culprit in not allowing the TCP connection. It made no difference.

With the firewall on or off, eMule will connect to eD2K and Kad networks but the files showing from a search is small.
I need to get it connected properly.

What is the reason for the blockage of the TCP?

Seeing that TCP will not connect with the firewall on or off, leads me to think that the problem is not with the firewall, Possibly has something to do with Sandbox settings and the way it talks to my router. I have never "forwarded ports" before. Do not know how to do that but am willing to try. My modem/router is the Netcomm NF18ACV.

I would appreciate any suggestions.


Update on 28/10/2021.

Upgraded to Windows 11 Pro.

The problem still remains.
Moving on.....
0

#3 User is offline   theoldfarter 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 30-January 07

Posted 06 November 2021 - 04:32 AM

Update on 06/11/2021.

Thought I would activate the built-in Virtual Machine & try that.
As I have never done that before, I enjoyed the new experience.

Alas, the TCP connection test failed. UPnP failed to setup port forwarding. That was with me allowing inbound & outbound connections in the Firewall, for eMule.

Disabled the Firewalls in the VM & the default install of Windows.
No change. TCP is still blocked.

Uninstalled the VM & disabled it & the Sandbox.

The technical fix for this is way above my knowledge.
I am just posting this for those who may wish to use eMule in these configurations, so they will not waste their time.
0

  • Member Options

Page 1 of 1

Fast Reply

  

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users