Official eMule-Board: Testing Emule 0.60A (Completed) - Official eMule-Board

Jump to content


  • (7 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »

Testing Emule 0.60A (Completed) Community version

#61 User is offline   idefix44 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 03-April 09

Posted 20 September 2020 - 12:31 AM

View Postfox88, on 19 September 2020 - 01:06 PM, said:

View Postidefix44, on 19 September 2020 - 01:07 PM, said:

About MiniMule, the cogwheel isn't displayed.

Here, with both 32-bit and 64-bit builds, the cogwheel was always displayed.
The 32-bit build was tested in 64-bit Windows 8.1 and in VirtualBox with 32-bit Windows XP SP3 (Internet Explorer's version 6.0.2900.5512).
To make sure nothing was broken in your Windows XP, please consider running chkdsk /f and, after that, sfc /scannow.

View Postidefix44, on 19 September 2020 - 01:07 PM, said:

The issue can it be the cogwheel icon ID ?

Can you please give a more detailed explanation?
These are GIF images, not icons. All the images are treated in the same way, giving no obvious reason for one of the buttons to become invisible.


Thanks for this quick answer,
My hardware runs perfectly well and the MiniMule cogwheel was correctly displayed with the 0.50a version wich ran 24/7 before I overwrite the .exe
with the 0.60a BETA.
About the icon ID, drop it :)

Have a good day.
0

#62 User is offline   MistressAdmin 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 21-August 20

Posted 20 September 2020 - 10:55 AM

I wonder if idefix44 problem could be down to not being a fresh install?
0

#63 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 20 September 2020 - 10:58 AM

View Postidefix44, on 20 September 2020 - 03:31 AM, said:

My hardware runs perfectly well

Excellent; but the suggested checks were about software, and would change nothing should the file system and OS be in perfect condition.

0.50a and 0.60a were compiled with different versions of Visual Studio, hence the changes in behaviour are possible.
Unfortunately, I could not reproduce your issue. Another MiniMule bug was found and fixed; but it is unknown if the two issues were related.
0

#64 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 338
  • Joined: 24-March 09

Posted 21 September 2020 - 09:40 AM

hi,

i've found a regression

21/09/2020 11:25:55: Failed to read shared directory "G:\DIRECTORY\" - Error 3
should be used the translation from IDS_ERR_SHARED_DIR from emule.rc (note: currently emule is setted to ENG)

the directory is from an external drive currently not connected to PC.

bye
0

#65 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 21 September 2020 - 02:41 PM

MistressAdmin,
it might be nice to try - but unlikely.

Riso64Bit,
please explain, what is the regression here, provided there are no translations in test builds.
0

#66 User is offline   andreaci 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 22-September 20

Posted 22 September 2020 - 06:29 AM

Hi Guys

I'm testing it now and it's way more stable than previous version (especially with big files) so far I found two problems:

- Cannot setup a upload limit without setting up a download limit. That wouldn't be a problem if I could change the download limit (but it's stuck to 50KB/s)
This is a big problem for us poor guys with only 1mbit/s in upload
- Huge freezing problems when the disk is "slow": the software freezes for minutes (not seconds) while starting a few big downloads rapidly or when I copy huge files on the download disk.
Everything keeps working in background (I can see data transfer and disk access), but the UI is completely frozen

An additional note:
The captcha on the forum is horrible and the registration mail says "This email has been sent from /index.php"
0

#67 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 22 September 2020 - 10:39 AM

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

it's way more stable than previous version (especially with big files)

You might have posted bug reports. Why there were none?

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

- Cannot setup a upload limit without setting up a download limit. That wouldn't be a problem if I could change the download limit (but it's stuck to 50KB/s)
This is a big problem for us poor guys with only 1mbit/s in upload

What is the download bandwidth, what capacity and limits were set, and what values you tried to enter (and how - sliders, direct number input)?

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

- Huge freezing problems when the disk is "slow": the software freezes for minutes (not seconds) while starting a few big downloads rapidly or when I copy huge files on the download disk.

Apparently, this is a stress test or an attempt to overload your system.
How sensible was this as a typical usage pattern?

This post has been edited by fox88: 23 September 2020 - 05:16 PM

0

#68 User is offline   Soul--Reaver 

  • Member
  • PipPip
  • Group: Members
  • Posts: 47
  • Joined: 15-February 03

Posted 22 September 2020 - 11:55 AM

Found an issue with shared dirs

The D:\Movies temp\Shared\ folder is not shown in the shared directories though the files in the folder are properly shared. I also have a folder d:\Movies\ that is shared
Tried adding a url to a screenshot but this forum seems to not allow that so the above description will have to suffice
0

#69 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 22 September 2020 - 02:33 PM

View PostSoul--Reaver, on 22 September 2020 - 02:55 PM, said:

The D:\Movies temp\Shared\ folder is not shown in the shared directories

Created "Movies temp" directory in the root of disk D:, inside of it created "Shared" directory.
Everything is visible in Options -> Directories, and in Shared Files, including a file copied to "Shared".
0

#70 User is offline   andreaci 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 22-September 20

Posted 22 September 2020 - 07:17 PM

View Postfox88, on 22 September 2020 - 11:39 AM, said:

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

it's way more stable than previous version (especially with big files)

It might have posted bug reports. Why there were none?

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

- Cannot setup a upload limit without setting up a download limit. That wouldn't be a problem if I could change the download limit (but it's stuck to 50KB/s)
This is a big problem for us poor guys with only 1mbit/s in upload

What is the download bandwidth, what capacity and limits were set, and what values you tried to enter (and how - sliders, direct number input)?

View Postandreaci, on 22 September 2020 - 09:29 AM, said:

- Huge freezing problems when the disk is "slow": the software freezes for minutes (not seconds) while starting a few big downloads rapidly or when I copy huge files on the download disk.

Apparently, this is a stress test or an attempt to overload your system.
How sensible was this as a typical usage pattern?




never posted bug reports because I started using emule again after years. I used 0.50 for a month (no reports because it was a dead project!) and then tried 0.60.


about the download limit:
I want to set it in this way
i . imgur . com/5L9PsZB_d.webp?maxwidth=728&fidelity=grand

but the software actually saves this (and it's impossible to change the "Download limit":
i . imgur . com/G4u595N_d.webp?maxwidth=728&fidelity=grand


about the disk-stress-thing: it's not so important. I noticed because I was moving a few movie files around.
The first time I killed emule, but I lost the donwloads.
The second time I opened performance monitor and I noticed it was still working.
0

#71 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 23 September 2020 - 05:24 PM

View Postandreaci, on 22 September 2020 - 10:17 PM, said:

about the download limit:
I want to set it in this way

The picture shows that you want to download at nearly 20 Mbit/s while uploading only 10 KB/s.

What would show speedtest.net site for your connection?
Of course, the test should be done with idle network.
0

#72 User is offline   Soul--Reaver 

  • Member
  • PipPip
  • Group: Members
  • Posts: 47
  • Joined: 15-February 03

Posted 23 September 2020 - 06:17 PM

View Postfox88, on 22 September 2020 - 04:33 PM, said:

View PostSoul--Reaver, on 22 September 2020 - 02:55 PM, said:

The D:\Movies temp\Shared\ folder is not shown in the shared directories

Created "Movies temp" directory in the root of disk D:, inside of it created "Shared" directory.
Everything is visible in Options -> Directories, and in Shared Files, including a file copied to "Shared".


Well finally found a way to share a screenshot.
Please enable the issues feature on github so that issues can be reported there

dropbox .com/s/ik4anl3v3ync55v/Untitled.png?dl=0

As you can see, both foldernames ending with "temp" are not shown in the list

It might be you need both folders with and without "temp". So a "Movies" folder and a "Movies temp" folder

This post has been edited by Soul--Reaver: 23 September 2020 - 06:21 PM

0

#73 User is offline   Soul--Reaver 

  • Member
  • PipPip
  • Group: Members
  • Posts: 47
  • Joined: 15-February 03

Posted 23 September 2020 - 06:28 PM

View Postandreaci, on 22 September 2020 - 09:17 PM, said:

never posted bug reports because I started using emule again after years. I used 0.50 for a month (no reports because it was a dead project!) and then tried 0.60.


about the download limit:
I want to set it in this way
i . imgur . com/5L9PsZB_d.webp?maxwidth=728&fidelity=grand

but the software actually saves this (and it's impossible to change the "Download limit":
i . imgur . com/G4u595N_d.webp?maxwidth=728&fidelity=grand


about the disk-stress-thing: it's not so important. I noticed because I was moving a few movie files around.
The first time I killed emule, but I lost the donwloads.
The second time I opened performance monitor and I noticed it was still working.


It seems eMule's minimum upload is 20kB these days for unrestricted download. This was 10kB in the past but i guess at some point this was changed

This post has been edited by Soul--Reaver: 23 September 2020 - 06:29 PM

0

#74 User is offline   p033928 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 74
  • Joined: 28-July 17

Posted 23 September 2020 - 07:34 PM

"It seems eMule's minimum upload is 20kB these days for unrestricted download. "..:
i think is true
0

#75 User is offline   Tlenl 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 23-April 20

Posted 24 September 2020 - 08:34 AM

Quote

- Huge freezing problems when the disk is "slow": the software freezes for minutes (not seconds) while starting a few big downloads rapidly or when I copy huge files on the download disk.
Everything keeps working in background (I can see data transfer and disk access), but the UI is completely frozen


I can confirm i had this same identical problem with 0.51d.

I was trying downloading this new build hoping this would be fixed but it seems is not.

In my case I have everything working on Samba Share drives (mounted with Letters),

so the "Disks" are not very low in latency (even if they are very fast anyway in common usage).

Indeed the emule gui is "sensitive" to disk latency (or just to samba shares) and in my case it's a continue freeze as i start downloading.

Everything working in the background however just fine, so it's only a Gui main cycle thread tuning.

Can this be done (just give the gui refresh thread a little more priority pheraps or fork an independent thread for the gui or fix the samba calls)?


EDIT:

This same problem of disk latency I think it's connected with the "You have unsufficient disk space" i had,

that can only be solved with "Allocate full space for not sparse files", thus relieving the same latency problem on the disk calls.


All in all, a tuning for "slow latency disks" (or samba) it's pheraps needed.

This post has been edited by Tlenl: 24 September 2020 - 08:44 AM

0

#76 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4743
  • Joined: 13-May 07

Posted 24 September 2020 - 10:21 AM

Soul--Reaver,
the directory tree issue will be fixed. Thanks for the report.

This post has been edited by fox88: 24 September 2020 - 10:41 AM

0

#77 User is offline   Tlenl 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 23-April 20

Posted 24 September 2020 - 12:26 PM

As an update to my previous post (i'm not able to edit it).

Tested entirely from scratch with NFS shares. Same freezing behaviour.

So it's not specifically samba related, but pheraps related to network shares or (again) slow latency path.
0

#78 User is offline   Enig123 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 519
  • Joined: 22-November 04

Posted 25 September 2020 - 02:31 AM

Well, since eMule's writing to disk is synchronous/blocking, merely busy disk by other programs is enough to cause UI stutter.

In your case, using of Samba means high latency with writing, which makes it even worse. I'd suggest you downloading in local disks while sharing on Samba drives for now.

This post has been edited by Enig123: 25 September 2020 - 08:02 AM

0

#79 User is offline   Tlenl 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 23-April 20

Posted 25 September 2020 - 06:30 AM

@Enig123
I see, thanks, so the GUI thread at this stage is not asynch by itself and blocked by writes.

Not an unbereable problem at the moment for me the gui freeze (well it's not nice but as long as the downloads are correct no probl).

I'll think about temping on local disk or just live with it.

I Hope the asynching of the gui (and so the problem solution) will be implemented as soon.
0

#80 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 338
  • Joined: 24-March 09

Posted 01 October 2020 - 12:29 PM

View PostRiso64Bit, on 21 September 2020 - 11:40 AM, said:

hi,

i've found a regression

21/09/2020 11:25:55: Failed to read shared directory "G:\DIRECTORY\" - Error 3
should be used the translation from IDS_ERR_SHARED_DIR from emule.rc (note: currently emule is setted to ENG)

the directory is from an external drive currently not connected to PC.

bye


hi and sorry for delay.
emule by default shows the ids from emule.rc if is set to ENG or if in another language doesnt exist the traslation, correct? if YES why shows "ERROR 3" and not the IDS correct IDS_ERR_SHARED_DIR "Failed to read shared directory ""%s"" - %s"?

This post has been edited by Riso64Bit: 01 October 2020 - 12:29 PM

0

  • Member Options

  • (7 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »

4 User(s) are reading this topic
0 members, 4 guests, 0 anonymous users