Official eMule-Board: Emule 0.51B Scheduler Bug - Official eMule-Board

Jump to content


Page 1 of 1

Emule 0.51B Scheduler Bug

#1 User is offline   h0rnytoad1 

  • Member
  • PipPip
  • Group: Members
  • Posts: 40
  • Joined: 20-April 06

Posted 01 February 2019 - 08:17 PM

Hello all,

the scheduler is buggy in emule 0.51a and 0.51b, i can't edit the actions i set in the scheduler if i close then re-open the settings window.

Not sure if they are saved to file as they do not appear in the options window but there are blank lines instead.



ps: how do i attach an image of the problem ?


0

#2 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4638
  • Joined: 13-May 07

Posted 02 February 2019 - 09:10 AM

Thanks for the report.
Unfortunately, editing and display were broken (other scheduler's functions should be fine), and it was not found while testing.
As a workaround, older versions of eMule could be used for schedule editing. Copy-pasting schedule settings in preferences.ini may be possible too.
The next version should have this issue fixed.
0

#3 User is offline   h0rnytoad1 

  • Member
  • PipPip
  • Group: Members
  • Posts: 40
  • Joined: 20-April 06

Posted 20 March 2019 - 12:15 AM

View Postfox88, on 02 February 2019 - 05:10 AM, said:

Thanks for the report.
Unfortunately, editing and display were broken (other scheduler's functions should be fine), and it was not found while testing.
As a workaround, older versions of eMule could be used for schedule editing. Copy-pasting schedule settings in preferences.ini may be possible too.
The next version should have this issue fixed.


thanks Fox88, it's very appreciated :)

i noticed a couple other bugs, or annoyances really, like after a download finishes it finalises and all is good but if i refresh the shares or close and relaunch emule, the finished downloads get rehashed and removed from the finished downloads list.
0

#4 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4638
  • Joined: 13-May 07

Posted 20 March 2019 - 10:57 AM

View Posth0rnytoad1, on 20 March 2019 - 03:15 AM, said:

i noticed a couple other bugs

It is highly advisable to use the rule: one bug - one topic.

View Posth0rnytoad1, on 20 March 2019 - 03:15 AM, said:

after a download finishes it finalises and all is good but if i refresh the shares or close and relaunch emule, the finished downloads get rehashed and removed from the finished downloads list.

That could be file system errors; no such behaviour here.
What is written in Log and Verbose panes?
0

#5 User is offline   h0rnytoad1 

  • Member
  • PipPip
  • Group: Members
  • Posts: 40
  • Joined: 20-April 06

Posted 25 March 2019 - 11:14 PM

i think i have an idea why this problem happens:

First, the files shared in Emule are stored on my NAS. So network shares, unc paths, and mapped drives.

Emule only shows my C drive when adding or editing categories, it doesn't show the mapped drives as if it were started with admin privs which of course it isn't.

So then i had to set the category's folders to my server's unc paths.

But in Emule's shares window, it's the contrary: it sees the mapped drives but not the unc paths.

So when i added mapped drives in the shares window to my shares, my theory is that Emule gets confused because it's not the same paths (unc in Categories, mapped drives in Shares).

That said, i don't know why they would disappear after rehashing them, but i remember seeing that bug before years and years ago.
0

#6 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4638
  • Joined: 13-May 07

Posted 26 March 2019 - 08:09 AM

View Posth0rnytoad1, on 26 March 2019 - 02:14 AM, said:

That said, i don't know why they would disappear after rehashing them, but i remember seeing that bug before years and years ago.

Not a scheduler-related issue.

Is everything configured in Directories page?
0

#7 User is offline   h0rnytoad1 

  • Member
  • PipPip
  • Group: Members
  • Posts: 40
  • Joined: 20-April 06

Posted 27 March 2019 - 02:22 AM

yes, i set a local temp on the C drive and the Finished folder on the E drive.

i also changed my categories to the E drive for testing and the hashing still removes the finished files.


0

#8 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4638
  • Joined: 13-May 07

Posted 27 March 2019 - 08:00 AM

Assuming that the scheduler is fixed, let's close this issue.
To discuss NAS and/or mapped drives, please create a separate report (and try to search around for similar problems in the forum).
0

  • Member Options

Page 1 of 1

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users