Official eMule-Board: Testing Version 0.51A - Official eMule-Board

Jump to content


  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »

Testing Version 0.51A Continued unofficial development

#21 User is offline   pier4r 

  • Ex falso quodlibet ; Kad is the major concept behind emule.
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 572
  • Joined: 31-March 09

Posted 02 June 2018 - 10:23 AM

I did not try it but kudos for the effort!
>>> My wiki (ITA) on emule >>>Feature Request (ICS) or SOTN, ClientAnalyzer(fixing fastXs and reask punishment),, EmuleCollectionV2 >>> Emule on old hardware (intel pentium 2 or 3 - via c3 - and so on) with good OS settings and enough ram (256+ mb): great >>>user of: eMule - Xtreme - ZZUL bastard - SharX - SharkX 1.8b5 pierQR - ZZUL-Tra - ZZUL-Tra-TL - kMule - Beba

Extended signature: click.
0

#22 User is offline   emule_user_downunder 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 53
  • Joined: 20-March 04

Posted 05 June 2018 - 09:58 AM

I see 0.51A beta 7 has been out for a while.
It appears stable as the older 0.50a.

The outstanding bugs in the forums do not have 'fixed by version xxx' to close them off and have confirmations from users that they indeed have been remedied. Is this desirable (I am used to this from developers on other forums for other products)
Can we sticky this topic and unsticky the 'Emule 0.50B Beta1 Released' topic if it has been superseded by this version, or are they diverging forks of the original 0.50a version that has been around for so long? Can somebody clarify this please.

0

#23 User is offline   SS1900 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 3676
  • Joined: 15-November 08

Posted 10 June 2018 - 07:54 AM

@ foxx88
Any news or update ?

:flowers:
0

#24 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 10 June 2018 - 12:14 PM

Second beta is ready for testing.

A number of bugs and regressions were fixed.
Additionally:
Speed limits should allow gigabit connections.
Allow mediainfo.dll up to 18.05.* version.
MobileMule code was removed.
4

#25 User is offline   demonsaw 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 7
  • Joined: 11-March 17

Posted 16 June 2018 - 11:55 AM

Thank you, I'll test it.
0

#26 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 17 June 2018 - 07:32 PM

Next build is ready.
Upload sessions with slow peers are expected to be starting more reliably.

This is a release candidate.

There were no changes in webinteface_v0.51a.zip since the previous build (second beta).
2

#27 User is offline   emule_user_downunder 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 53
  • Joined: 20-March 04

Posted 23 June 2018 - 08:11 AM

So 50b beta versions is now obsolete? Have the changes in 50.x since the last production release been rolled into the 51a beta stream?

Minor bug: I have run 51a beta 9 and notice the servers screen panel contents that shows the Log, Server Info and Verbose logging activity often is not left justified, and the text displays with an offset of 20-30 characters from the left. This is slightly annoying, especially as it is not able to be consistently reproduced. Are the display justification attributes for that box extracted from the system (I am thinking of language situations where left justification is not the default), or have they been initialised somewhere?

ServerWnd, RichEditCtrlX, MuleListCtrl ??

This post has been edited by emule_user_downunder: 23 June 2018 - 10:08 AM

0

#28 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 23 June 2018 - 02:05 PM

View Postemule_user_downunder, on 23 June 2018 - 11:11 AM, said:

So 50b beta versions is now obsolete?

This is the latest official beta, and no official 0.50b release, only 0.50a.

View Postemule_user_downunder, on 23 June 2018 - 11:11 AM, said:

Minor bug

An example screenshot would be nice to see.

This post has been edited by fox88: 23 June 2018 - 05:44 PM

0

#29 User is offline   nephtys59 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 11-January 03

Posted 24 June 2018 - 06:52 PM

The release candidate 51a works like a charm, but crashes whenever I use the "clear completed" command.
Windows 7 x64
0

#30 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 24 June 2018 - 07:27 PM

nephtys59,
I could not reproduce it.
Can you create a crash dump?
0

#31 User is offline   DJKuhpisse 

  • Member
  • PipPip
  • Group: Members
  • Posts: 34
  • Joined: 06-September 16

Posted 25 June 2018 - 10:18 AM

Why is that a non-official Beta?
Is the official development-team not working anymore?
0

#32 User is offline   nephtys59 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 11-January 03

Posted 25 June 2018 - 04:39 PM

View Postfox88, on 24 June 2018 - 08:27 PM, said:

nephtys59,
I could not reproduce it.
Can you create a crash dump?


I have enabled Crushdump in the preferences.ini file, will send you as soon as I have a completed file so that I can cause the crash.
0

#33 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 25 June 2018 - 06:00 PM

nephtys59,
thanks in advance.
To speed up things, any small file with many sources from search will do. Or something from Content-DB.
0

#34 User is offline   Coool 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 25-June 18

Posted 25 June 2018 - 06:27 PM

View Postnephtys59, on 24 June 2018 - 06:52 PM, said:

The release candidate 51a works like a charm, but crashes whenever I use the "clear completed" command.
Windows 7 x64


  • Same issue only using Windows 32-bit.
  • Can't change to Latvian language - before starting eMule copied lv_LV.dll from eMule0.50b_unofficial.zip lang folder and set Language=1062 in preferences.ini. Deletes file on start. Changing to Latvian in Options asks to download from web with fail

    Quote

    Failed to receive a valid HTTP response from the server
    Failed to download and install selected language library from http://langmirror1.e...5109/lv_LV.dll!

0

#35 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 25 June 2018 - 09:23 PM

New build for testing (release candidate 2).

Again, no changes in webinteface_v0.51a.zip.

If crash on "Clear completed" still occurs, please make a crash dump.
No language dlls for test builds should be expected.
0

#36 User is offline   Coool 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 25-June 18

Posted 26 June 2018 - 07:00 AM

View Postfox88, on 25 June 2018 - 09:23 PM, said:

New build for testing (release candidate 2).
...

If crash on "Clear completed" still occurs, please make a crash dump.
No language dlls for test builds should be expected.


  • "Clear completed" is working
  • Do you add language support later?
  • Using Search Automatic, Server and Global (Servers) do nothing (find nothing). Works only Kad.

This post has been edited by Coool: 26 June 2018 - 08:46 AM

0

#37 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 26 June 2018 - 07:02 AM

Cool, thanks for the report.
Language dlls will be in release.
0

#38 User is offline   Coool 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 25-June 18

Posted 26 June 2018 - 08:08 AM

fox88, have you read 3. point - Using Search Automatic, Server and Global (Servers) do nothing (find nothing). Works only Kad.

This post has been edited by Coool: 26 June 2018 - 08:46 AM

0

#39 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4561
  • Joined: 13-May 07

Posted 26 June 2018 - 05:36 PM

View PostCoool, on 26 June 2018 - 10:00 AM, said:

Using Search Automatic, Server and Global (Servers) do nothing (find nothing). Works only Kad.

All search methods are working here.
Please check eMule's configuration, because "not working" is is not the same as "finds nothing".
0

#40 User is offline   Coool 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 25-June 18

Posted 26 June 2018 - 05:55 PM

fox88,

  • Tried search Playboy found nothing using Using Search Automatic, Server and Global (Servers). Posted Image
  • Switching Categories (lot of files), lost currently downloading files list and starts downloading other files. (Slow CPU for todays standarts)
  • How about Multi CPU support (seeing only one core using)!

This post has been edited by Coool: 26 June 2018 - 06:12 PM

0

  • Member Options

  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users