Official eMule-Board: Windows 7 Professional X64 Trouble - Official eMule-Board

Jump to content


Page 1 of 1

Windows 7 Professional X64 Trouble

#1 User is offline   LambdaFox 

  • Member
  • PipPip
  • Group: Members
  • Posts: 39
  • Joined: 02-July 04

Posted 03 January 2017 - 07:22 PM

I use Private Internet Access VPN. After connecting to one of their port-forwarding servers, the icon in the system tray tells me the random port I am assigned. In XP, I did not have to do any special firewall rules, I simply put the port in the TCP and UDP boxes in the emule options and it worked.

I have a new machine that is running Windows 7 Professional 64-bit.

I have not been able to get emule to pass the TCP test and am getting lowid.

I edited emule's firewall rules to match this aricle.

When I tried to save the first rule, I got an error:

Error: The parameter is incorrect

Status: 'Defer to user' setting can only be used in a firewall rule where program path and TCP/UDP protocol are specified with no additional scopes.

This article suggested changing edge traversal on the Advanced tab of the rules to "allow...".

That let me apply the rules.

After this, I still am not able to pass the TCP test or get high id from the servers. Kad does not connect at all.

I did try running emule in xp sp3 compatibility mode. That did not get me through my road block.

Anyone have a solution?

Do you know how to tweak windows firewall rules to solve this in Windows 7 Pro 64-bit?

Or, do you know of a firewall replacement that would solve my problem?

Other ideas?

This post has been edited by LambdaFox: 03 January 2017 - 07:26 PM

0

#2 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7867
  • Joined: 20-August 08

Posted 03 January 2017 - 08:12 PM

Did you try with the firewall disabled few minutes, just for curiosity?
INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Posted Image
0

#3 User is offline   LambdaFox 

  • Member
  • PipPip
  • Group: Members
  • Posts: 39
  • Joined: 02-July 04

Post icon  Posted 04 January 2017 - 06:41 PM

I searched through my VPN's support forums and discovered that any software using the port forwarding feature has to be set up differently. As I understand it all of the data ends up going through the one port the VPN creates. For eMule to work I had to change the Windows 7 Firewall TCP and UDP rules to allow "All Ports". After doing this, eMule will successfully complete the port test.

Quite by accident, I found one weird twist. The Private Internet Access client must be run as administrator. If I set the application to auto-start at boot, this does not seem to happen. This produces this weird side effect:

If I manually start the client, Windows asks me to click the box to allow changes to my system After doing this, the port test succeeds and I get highid.

But, if I set the client to auto-start with Windows, I do not get the Windows confirmation box. After doing it this way, eMule also passes the port test, BUT I get lowid!
0

#4 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7867
  • Joined: 20-August 08

Posted 07 January 2017 - 11:57 PM

Hence, solved? :)
INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Posted Image
0

  • Member Options

Page 1 of 1

Fast Reply

  

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users