Official eMule-Board: New Version With Ipv6 Support - Official eMule-Board

Jump to content


Page 1 of 1

New Version With Ipv6 Support Rate Topic: -----

#1 User is offline   luckybuilding 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 21-December 16

Posted 21 December 2016 - 11:37 PM

Dear All,
I have been occational user of the emule for the previous decade. I ever wondered why there was no new version for this solution including some needed features such as IPv6!
As this software generates LOW ID for users behind NAT, enabling IPv6 makes more users able to share using High ID.

Would there be any other version for the software soon or not?

Thanks
0

#2 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3626
  • Joined: 27-June 03

Posted 22 December 2016 - 12:00 AM

There are several reason why there is no IPv6 support:

The most important and practical one: Currently there is not enough development power for the official version to implement such such a major feature. Related to that is the fact that there are unsolved problems: Servers won't support IPv6 (because the server software isn't developed anymore) and for Kad's DHT IPv6 is a security problem (the current one relies on IPs being a scarce ressource to prevent an attacker from impeding / overtaking the network / routing tables and IPv6 isn't scarce anymore). Those issues could most likely be solved - with enough time.

Some mods have done their own implementations already which work, but don't solve the Kad problem (which won't become obvious until it's juicy enough for an attacker to exploit the weakness - so untill the majority of Kad has switched).

#3 User is offline   guknos 

  • Member
  • PipPip
  • Group: Members
  • Posts: 37
  • Joined: 07-November 15

Posted 22 December 2016 - 06:22 PM

View PostSome Support, on 22 December 2016 - 12:00 AM, said:

Servers won't support IPv6 (because the server software isn't developed anymore)

discard servers and use kad only :D

seriously, do you have some plan for the 0.50b? :)

This post has been edited by guknos: 22 December 2016 - 06:23 PM

0

#4 User is offline   Angvil 

  • Member
  • PipPip
  • Group: Members
  • Posts: 20
  • Joined: 27-October 09

Posted 18 February 2017 - 12:56 PM

View Postguknos, on 23 December 2016 - 02:22 AM, said:

View PostSome Support, on 22 December 2016 - 12:00 AM, said:

Servers won't support IPv6 (because the server software isn't developed anymore)

discard servers and use kad only :D

seriously, do you have some plan for the 0.50b? :)

Some Support hate IPV6 and NAT-T,and neoloader support IPv6
0

  • Member Options

Page 1 of 1

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users