Official eMule-Board: Current Source Code - Official eMule-Board

Jump to content


  • (27 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »

Current Source Code

#21 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 10 August 2013 - 12:49 PM

View Postfox88, on 10 August 2013 - 11:34 AM, said:

Path to template file is defined in preferences.ini

Of course, anyway I can access WebInterface.

Posted Image

eMule keep crashing. I send a crash dump by email.
0

#22 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 336
  • Joined: 24-March 09

Posted 10 August 2013 - 01:10 PM

First Runtime Wizard:

runnig FRW under Windows XP SP3 i have some graphical issue( check box not ALLIGNED whit the corresponding TEXT)
Posted Image
Posted Image
Posted Image

Quote

eMule.tmpl is in config folder, in webaserver folder there are .gif files and an .ico file.

Running in a new folder eMule.exe:
1) eMule.tmpl is NOT in config folder
2) webserver folder is EMPTY



I can confirm this bug (zangune post n° 17)

Quote

10/08/2013 15.18.21: Adding client to upload list: Direct add with empty queue. Client: 5843438@91.200.42.46 (151.52.29.87) 'http://emule-project.net' (eMule v0.50a,None/None/None)
10/08/2013 15.18.23: IO Error: GetOverlappedResult: L'evento di I/O sovrapposto non è in uno stato segnalato.
10/08/2013 15.18.23: Removing client from upload list: IO/Other Error while creating datapacket (see earlier log entries) Client: 5843438@91.200.42.46 (151.52.29.87) 'http://emule-project.net' (eMule v0.50a,None/Uploading/None) Transferred: 1 secs SessionUp: 536 Bytes QueueSessionPayload: 0 Bytes In buffer: 290.00 KB Req blocks: 1 File: nameoffile.rar


Quote

10/08/2013 15.22.27: Adding client to upload list: Direct add with empty queue. Client: 7002460@91.200.42.46 (84.222.81.153) 'http://emule-project.net' (eMule v0.50a,None/None/None)
10/08/2013 15.22.27: IO Error: GetOverlappedResult: L'evento di I/O sovrapposto non è in uno stato segnalato.
10/08/2013 15.22.27: Removing client from upload list: IO/Other Error while creating datapacket (see earlier log entries) Client: 7002460@91.200.42.46 (84.222.81.153) 'http://emule-project.net' (eMule v0.50a,None/Uploading/None) Transferred: 0 secs SessionUp: 0 Bytes QueueSessionPayload: 0 Bytes In buffer: 230.00 KB Req blocks: 1 File: .7z

This post has been edited by Riso64Bit: 10 August 2013 - 01:27 PM

0

#23 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4712
  • Joined: 13-May 07

Posted 10 August 2013 - 01:22 PM

View PostRiso64Bit, on 10 August 2013 - 04:10 PM, said:

Running in a new folder eMule.exe:
1) eMule.tmpl is NOT in config folder
2) webserver folder is EMPTY

To get template files and webserver directory, you need to run installer or unpack binaries.
The FRW cannot help here.
0

#24 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 10 August 2013 - 02:00 PM

View PostRiso64Bit, on 10 August 2013 - 03:10 PM, said:

Running in a new folder eMule.exe:
1) eMule.tmpl is NOT in config folder
2) webserver folder is EMPTY

How did you install eMule 0.50b BETA 3?

Download eMule0.50a.zip, extract eMule0.50a.zip, in example in C:\eMule0.50a, run it, close it, download emule_devbranch_bin.zip, extract emule_devbranch_bin.zip, open emule_devbranch_bin folder, copy emule.exe from there, open C:\eMule0.50a folder rename emule.exe as emule.050a, paste new emule.exe, the one you copied from emule_devbranch_bin folder, run eMule.
If you use your yet installed eMule to test and then want to get back to eMule 0.50a, you have to download again italian language dll and sometimes it fails because of langmirror3 is empty.

This post has been edited by Zangune: 10 August 2013 - 02:02 PM

0

#25 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4712
  • Joined: 13-May 07

Posted 10 August 2013 - 09:43 PM

Dump #2

PS. Another dump was not created, because Win7-64 decided that eMule stopped responding, and the dump dialog was closed because the task was terminated.

This post has been edited by fox88: 11 August 2013 - 11:34 AM

0

#26 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 11 August 2013 - 08:58 AM

View PostZangune, on 10 August 2013 - 04:00 PM, said:

If you use your yet installed eMule to test and then want to get back to eMule 0.50a

Please don't do that, it messed up Accepted Requests in Shared Files to me.

Anyway I get a lot of LowIDs on servers with eMule 0.50b BETA 3. Fake LowID, of course.

This post has been edited by Zangune: 11 August 2013 - 09:01 AM

0

#27 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7907
  • Joined: 20-August 08

Posted 11 August 2013 - 09:08 AM

Did you backup the config folder?
INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Immagine Postata
0

#28 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 336
  • Joined: 24-March 09

Posted 11 August 2013 - 09:13 AM

3 DUMPs
http://temp-share.com/show/3Yg8HWw9x

0

#29 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 11 August 2013 - 09:16 AM

View Postxilolee, on 11 August 2013 - 11:08 AM, said:

Did you backup the config folder?

No, I didn't. Fortunately, nothing else seems messed up.

This post has been edited by Zangune: 11 August 2013 - 09:19 AM

0

#30 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7907
  • Joined: 20-August 08

Posted 11 August 2013 - 09:24 AM

Has someone else observed that the server connection happens without obfuscation?

This post has been edited by xilolee: 11 August 2013 - 09:29 AM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Immagine Postata
0

#31 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 11 August 2013 - 09:38 AM

View Postxilolee, on 11 August 2013 - 11:24 AM, said:

Has someone else observed that the server connection happens without obfuscation?

True.
0

#32 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7907
  • Joined: 20-August 08

Posted 11 August 2013 - 09:41 AM

Crash dump

- Windows 8 64 bit - 4GB ram
- emule installation folder in c:\program files(x86)\emule, and the other folders are inside it
- temp and incoming folders are in d:
- emule started as administrator (by using tasks scheduler)

It happened soon after i clicked OK, when I was enabling every options/check boxes inside options -> display under "show percentage..." and disabled the "disable checkboxes" under "save cpu & memory usage" (i.e., I was enabling the known clients and queue lists).


I used dumpchk file.dmp to show the following informations:
dumpchk "C:\Program Files (x86)\eMule\Config\eMule_0-50b-5_20130811-112911.dmp"  > %userprofile%\desktop\emuledump.txt

Spoiler


I used this command to show the stored exception (showed in bold in the previous spoiler)... Anyway it says "symbol search path is invalid":
cdb -z "C:\Program Files (x86)\eMule\Config\eMule_0-50b-5_20130811-112911.dmp" -logo %userprofile%\desktop\out.txt -lines -c "!analyze -v;.ecxr;!for_each_frame dv /t;q"


Spoiler

This post has been edited by xilolee: 11 August 2013 - 10:42 AM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Immagine Postata
0

#33 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 11 August 2013 - 09:50 AM

View Postxilolee, on 11 August 2013 - 11:41 AM, said:

It happened soon after i clicked OK, when I was enabling every options/check boxes inside options -> display under "show percentage..." and disabled the "disable checkboxes" under "save cpu & memory usage" (i.e., I was enabling the known clients and queue lists).

I can't reproduce it, Windows XP.
Are you uploading something with eMule? Nevermind, the answer is yes.

This post has been edited by Zangune: 11 August 2013 - 10:02 AM

0

#34 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3649
  • Joined: 27-June 03

Posted 11 August 2013 - 01:52 PM

I have uploaded a fix for the IO file reading crash.

Also please do not report bugs/stuff with is not actually related to the dev branch - so appears with older versions too - in this thread.

#35 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 11 August 2013 - 05:12 PM

Version 0.50.1.6 still upload problems. Windows XP.

Servers -> Verbose red messages are what you need, aren't they?

Quote

11/08/2013 18.55.46: ReadCompletetionRoutine: Didn't read requested datacount - wanted: 184320, read: 0
11/08/2013 18.55.46: Removing client from upload list: IO/Other Error while creating datapacket (see earlier log entries) Client: X@Y 'Z' (eMule v0.50a,None/Uploading/None) Transferred: 17 secs SessionUp: 215.82 KB QueueSessionPayload: 222.47 KB In buffer: 360.00 KB Req blocks: 0

Quote

11/08/2013 18.57.41: ReadCompletetionRoutine: Didn't read requested datacount - wanted: 184320, read: 0

Posted Image

It continues this way.
0

#36 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3649
  • Joined: 27-June 03

Posted 11 August 2013 - 05:44 PM

I will have to set up a Windows XP VM when I have the time to check if the overlapped reading behaves differently / unexpected on it.

#37 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7907
  • Joined: 20-August 08

Posted 11 August 2013 - 05:48 PM

The server issue is present yet...
Uhm... This time I had four crashes when I was in the transfers - on queue list

eMule_0-50b-6_20130811-194817.dmp
eMule_0-50b-6_20130811-195715.dmp
eMule_0-50b-6_20130811-204243.dmp

On queue list disabled, crashes disappeared.

This post has been edited by xilolee: 11 August 2013 - 06:48 PM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Immagine Postata
0

#38 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3649
  • Joined: 27-June 03

Posted 11 August 2013 - 07:50 PM

View Postxilolee, on 11 August 2013 - 06:48 PM, said:

The server issue is present yet...
Uhm... This time I had four crashes when I was in the transfers - on queue list

eMule_0-50b-6_20130811-194817.dmp
eMule_0-50b-6_20130811-195715.dmp
eMule_0-50b-6_20130811-204243.dmp

On queue list disabled, crashes disappeared.


Yes that's a crash related to the dev branch changes, will be fixed.

#39 User is offline   Enig123 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 518
  • Joined: 22-November 04

Posted 11 August 2013 - 08:49 PM

Does the crashes related to the NULL pUpClientStruct within CUpDownClient::DrawUpStatusBar() which also invoked by queuelistctrl?

Also with the change of definision of uploadinglist,
bool	IsDownloading(CUpDownClient* client)	const {return (uploadinglist.Find(client) != 0);}

does not work as it should anymore.

There's another problem emerged as the consequence of CUploadQueue::IsDownloading not working. I have spotted rare cases in which multiple same client getting into the uploadinglist and when finished downloading (from us) and getting out of uploadinglist, which causes
Unknown CMemoryException exception in CUploadQueue::UploadTimer - Out of memory.


That reminds me of how does it happened anyway. How can we prevent duplicate client pointer in the waitinglist in the first place? As I checked, the routine CUploadQueue::RemoveFromUploadQueue() does have dupcheck by its own.

This post has been edited by Enig123: 11 August 2013 - 08:55 PM

0

#40 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4712
  • Joined: 13-May 07

Posted 11 August 2013 - 09:34 PM

I think something could be tweaked in SVN: all the files in .zip get the same date/time; apparently time of .zip creation.
While the expected behaviour was to have the last modification time for each file.

Also it might be useful to add a link to .pdb file for your builds.
0

  • Member Options

  • (27 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »

2 User(s) are reading this topic
0 members, 2 guests, 0 anonymous users