Official eMule-Board: Current Source Code - Official eMule-Board

Jump to content


  • (27 Pages)
  • +
  • 1
  • 2
  • 3
  • Last »

Current Source Code

#1 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3628
  • Joined: 27-June 03

Posted 06 August 2013 - 07:02 PM

I have uploaded the current source code for eMule into the project repository on SF. The default branch contains the last stable release, the dev branch all changes since then (which are yet unpublished). I don't think I have to mention that stuff in there will be untested and possibly buggy - but should compile.

The biggest change for 0.50b is currently a rework of the upload / disk IO mechanics to switch to asynchronous operations , allowing to OS to optimize the disk access better and upload much faster on big lines. Otherwise there are some fixes and optimizations.

In general you should not reuse protocol related changes for your mods before they are released, because they might still change and break old versions of the dev branch (there are no major protocol changes currently though). Otherwise just keep in mind that it's untested.

Obviously I don't recommend to use this branch for end users, but since some might want to try anyway I will provide a binary for the current dev code now and then. Here. (current build: 16)

This post has been edited by Some Support: 25 April 2015 - 02:57 PM


#2 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4473
  • Joined: 13-May 07

Posted 07 August 2013 - 06:42 AM

Thanks a lot.
0

#3 User is offline   SS1900 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 3657
  • Joined: 15-November 08

Posted 07 August 2013 - 07:25 AM

thx :flowers:
0

#4 User is offline   ]Axl[ 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 114
  • Joined: 31-January 05

Post icon  Posted 07 August 2013 - 10:56 AM

GREAT NEWS!!! Thanks!!!
0

#5 User is offline   tHeWiZaRdOfDoS 

  • Man, what a bunch of jokers...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5630
  • Joined: 28-December 02

Posted 07 August 2013 - 11:46 AM

Great idea, SS - thx! :worthy:
0

#6 User is offline   Tuxman 

  • lizzie and prog-rock fanatic
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 2692
  • Joined: 26-July 04

Posted 07 August 2013 - 12:31 PM

Wondering why you changed your policy of not releasing "in-development" code. Anyway, already dug through it. Seems nice!
[ eMule beba ] :: v2.72 released, v3.00 in the works ...
- feel the lightweight! - featuring Snarl support, the Client Analyzer and tits!
Coded by a Golden eMule Award winner and most people's favorite modder!
..........................................
Music, not muzak:
Progressive Rock :: my last.fm profile
..........................................
eMule user since 0.28 ...
-[ ... and thanks for all the fish! ]-
0

#7 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3628
  • Joined: 27-June 03

Posted 07 August 2013 - 01:11 PM

View PostTuxman, on 07 August 2013 - 01:31 PM, said:

Wondering why you changed your policy of not releasing "in-development" code.


Because of the large time gaps between releases. When eMule version were released every few months, there wasn't a huge drawback in not publishing the code till then, but now that it is rather years it seems to make more sense to allow viewing and merging it before.

#8 User is offline   Tuxman 

  • lizzie and prog-rock fanatic
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 2692
  • Joined: 26-July 04

Posted 07 August 2013 - 01:16 PM

I'd assume the opposite. I wish I had had such a huge time gap to merge a mod when 0.47x was current.

But I like the new direction. :)
[ eMule beba ] :: v2.72 released, v3.00 in the works ...
- feel the lightweight! - featuring Snarl support, the Client Analyzer and tits!
Coded by a Golden eMule Award winner and most people's favorite modder!
..........................................
Music, not muzak:
Progressive Rock :: my last.fm profile
..........................................
eMule user since 0.28 ...
-[ ... and thanks for all the fish! ]-
0

#9 User is offline   loverboy 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 372
  • Joined: 17-September 06

Posted 07 August 2013 - 04:39 PM

Great news
Thanks a lot :flowers:
0

#10 User is offline   hooligan3000 

  • www.sharing-devils.to
  • PipPipPipPip
  • Group: Members
  • Posts: 243
  • Joined: 19-December 09

Posted 08 August 2013 - 12:43 AM

http://www.xup.in/dl,24436511/eMule_0-50b-5_20130808-023114.dmp/
dmp file :confused:
ed2k-Server: !!! Sharing-Devils No1 !!! - offline
ed2k-Server: !!! Sharing-Devils No2 !!! - offline
ed2k-Server: !!! Sharing-Devils No3 !!! - offline

Sharing-Devils

Serverlist offline

IP-Filter by Hooligan
use a VPN for more fun with eMule
0

#11 User is offline   Enig123 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 493
  • Joined: 22-November 04

Posted 08 August 2013 - 05:38 AM

I've got an error message in the log with the new code:
8/7/2013 10:29:39 PM: WSASend() Error: 10022, An invalid argument was supplied.

which seems to originate from the new introduced routine CEMSocket::SendOv().
0

#12 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4473
  • Joined: 13-May 07

Posted 09 August 2013 - 07:27 PM

Server connection behaves oddly in 0.50b.

No configuration changes - only .exe file is replaced. 9 servers.
Loaded eMule and pressed Connect icon.

v0.50a
09/08/2013 23:05:40: Connecting
09/08/2013 23:05:40: Connecting to eMule Security No2 (91.200.42.47:3883 - using Protocol Obfuscation) ...
09/08/2013 23:05:40: Read 200 contacts from file.
09/08/2013 23:05:40: Connected to eMule Security No2 (91.200.42.47:3883), sending login request
09/08/2013 23:05:41: Obfuscated connection established on: eMule Security No2 (91.200.42.47:3883)
09/08/2013 23:05:41: New client ID is 2435001390


v0.50b
09/08/2013 23:21:55: Connecting
09/08/2013 23:21:55: Connecting to PEERATES.NET (88.191.221.121:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:55: Read 200 contacts from file.
09/08/2013 23:21:55: Connected to PEERATES.NET (88.191.221.121:7111), sending login request
09/08/2013 23:21:55: PEERATES.NET (88.191.221.121:7111) appears to be full
09/08/2013 23:21:55: Connecting to Aigame (117.18.121.3:5000 - using Protocol Obfuscation) ...
09/08/2013 23:21:55: Connected to Aigame (117.18.121.3:5000), sending login request
09/08/2013 23:21:56: Aigame (117.18.121.3:5000) appears to be full
09/08/2013 23:21:56: Connecting to Usenet-Deals.com No1 (91.200.42.119:9939 - using Protocol Obfuscation) ...
09/08/2013 23:21:56: Connected to Usenet-Deals.com No1 (91.200.42.119:9939), sending login request
09/08/2013 23:21:56: Usenet-Deals.com No1 (91.200.42.119:9939) appears to be full
09/08/2013 23:21:56: Connecting to TV Underground No1 (176.103.48.36:4184 - using Protocol Obfuscation) ...
09/08/2013 23:21:56: Connected to TV Underground No1 (176.103.48.36:4184), sending login request
09/08/2013 23:21:57: TV Underground No1 (176.103.48.36:4184) appears to be full
09/08/2013 23:21:57: Connecting to eMule Security No2 (91.200.42.47:3883 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to eMule Security No2 (91.200.42.47:3883), sending login request
09/08/2013 23:21:57: eMule Security No2 (91.200.42.47:3883) appears to be full
09/08/2013 23:21:57: Connecting to eMule Security No1 (91.200.42.46:1176 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to eMule Security No1 (91.200.42.46:1176), sending login request
09/08/2013 23:21:57: eMule Security No1 (91.200.42.46:1176) appears to be full
09/08/2013 23:21:57: Connecting to PEERATES.NET (88.190.202.44:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to PEERATES.NET (88.190.202.44:7111), sending login request
09/08/2013 23:21:57: PEERATES.NET (88.190.202.44:7111) appears to be full
09/08/2013 23:21:57: Connecting to Usenet-Deals.com No2 (77.120.115.66:5041 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to Usenet-Deals.com No2 (77.120.115.66:5041), sending login request
09/08/2013 23:21:58: Usenet-Deals.com No2 (77.120.115.66:5041) appears to be full
09/08/2013 23:21:58: Connecting to PeerBooter (88.191.228.66:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:58: Connected to PeerBooter (88.191.228.66:7111), sending login request
09/08/2013 23:21:58: PeerBooter (88.191.228.66:7111) appears to be full
09/08/2013 23:21:58: Connecting to PEERATES.NET (88.191.221.121:7111)...
09/08/2013 23:21:58: Connected to PEERATES.NET (88.191.221.121:7111), sending login request
09/08/2013 23:21:59: Connection established on: PEERATES.NET (88.191.221.121:7111)


Both times I get high ID.

PS. Some Support, will you open beta forum or we will report bugs and problems here?
0

#13 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 323
  • Joined: 24-March 09

Posted 09 August 2013 - 07:37 PM

View Postfox88, on 09 August 2013 - 09:27 PM, said:

Server connection behaves oddly in 0.50b.

No configuration changes - only .exe file is replaced. 9 servers.
Loaded eMule and pressed Connect icon.

v0.50a
09/08/2013 23:05:40: Connecting
09/08/2013 23:05:40: Connecting to eMule Security No2 (91.200.42.47:3883 - using Protocol Obfuscation) ...
09/08/2013 23:05:40: Read 200 contacts from file.
09/08/2013 23:05:40: Connected to eMule Security No2 (91.200.42.47:3883), sending login request
09/08/2013 23:05:41: Obfuscated connection established on: eMule Security No2 (91.200.42.47:3883)
09/08/2013 23:05:41: New client ID is 2435001390


v0.50b
09/08/2013 23:21:55: Connecting
09/08/2013 23:21:55: Connecting to PEERATES.NET (88.191.221.121:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:55: Read 200 contacts from file.
09/08/2013 23:21:55: Connected to PEERATES.NET (88.191.221.121:7111), sending login request
09/08/2013 23:21:55: PEERATES.NET (88.191.221.121:7111) appears to be full
09/08/2013 23:21:55: Connecting to Aigame (117.18.121.3:5000 - using Protocol Obfuscation) ...
09/08/2013 23:21:55: Connected to Aigame (117.18.121.3:5000), sending login request
09/08/2013 23:21:56: Aigame (117.18.121.3:5000) appears to be full
09/08/2013 23:21:56: Connecting to Usenet-Deals.com No1 (91.200.42.119:9939 - using Protocol Obfuscation) ...
09/08/2013 23:21:56: Connected to Usenet-Deals.com No1 (91.200.42.119:9939), sending login request
09/08/2013 23:21:56: Usenet-Deals.com No1 (91.200.42.119:9939) appears to be full
09/08/2013 23:21:56: Connecting to TV Underground No1 (176.103.48.36:4184 - using Protocol Obfuscation) ...
09/08/2013 23:21:56: Connected to TV Underground No1 (176.103.48.36:4184), sending login request
09/08/2013 23:21:57: TV Underground No1 (176.103.48.36:4184) appears to be full
09/08/2013 23:21:57: Connecting to eMule Security No2 (91.200.42.47:3883 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to eMule Security No2 (91.200.42.47:3883), sending login request
09/08/2013 23:21:57: eMule Security No2 (91.200.42.47:3883) appears to be full
09/08/2013 23:21:57: Connecting to eMule Security No1 (91.200.42.46:1176 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to eMule Security No1 (91.200.42.46:1176), sending login request
09/08/2013 23:21:57: eMule Security No1 (91.200.42.46:1176) appears to be full
09/08/2013 23:21:57: Connecting to PEERATES.NET (88.190.202.44:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to PEERATES.NET (88.190.202.44:7111), sending login request
09/08/2013 23:21:57: PEERATES.NET (88.190.202.44:7111) appears to be full
09/08/2013 23:21:57: Connecting to Usenet-Deals.com No2 (77.120.115.66:5041 - using Protocol Obfuscation) ...
09/08/2013 23:21:57: Connected to Usenet-Deals.com No2 (77.120.115.66:5041), sending login request
09/08/2013 23:21:58: Usenet-Deals.com No2 (77.120.115.66:5041) appears to be full
09/08/2013 23:21:58: Connecting to PeerBooter (88.191.228.66:7111 - using Protocol Obfuscation) ...
09/08/2013 23:21:58: Connected to PeerBooter (88.191.228.66:7111), sending login request
09/08/2013 23:21:58: PeerBooter (88.191.228.66:7111) appears to be full
09/08/2013 23:21:58: Connecting to PEERATES.NET (88.191.221.121:7111)...
09/08/2013 23:21:58: Connected to PEERATES.NET (88.191.221.121:7111), sending login request
09/08/2013 23:21:59: Connection established on: PEERATES.NET (88.191.221.121:7111)


Both times I get high ID.

PS. Some Support, will you open beta forum or we will report bugs and problems here?


I have the same identical problem & i can regenerate it:
(under XP sp3)
1 start 0.50b & connect to KAD & server
2 CLOSE (exit) emule WITHOUT disconnect Server & kad connectivity
3 try to reopen a new instance of emule & you obtein this log
0

#14 User is offline   Riso64Bit 

  • Magnificent Member
  • PipPipPipPipPipPip
  • Group: Members
  • Posts: 323
  • Joined: 24-March 09

Posted 09 August 2013 - 07:44 PM

I have the same problem whit older version.
why if you enable the webserver & click "Apply" emule generate an error: "emule can't load templates: ...." ?
Emule try to open "emule.tmpl" under the same folder of eMule.exe but it's not present & "webserver" folder is empty.
can you fix this?
0

#15 User is offline   Some Support 

  • Last eMule
  • PipPipPipPipPipPipPip
  • Group: Yes
  • Posts: 3628
  • Joined: 27-June 03

Posted 09 August 2013 - 08:43 PM

View Postfox88, on 09 August 2013 - 08:27 PM, said:

PS. Some Support, will you open beta forum or we will report bugs and problems here?


No, it's not a Beta yet. This also means I will not respond/fix everything which seems wrong, as some thing are just untested yet (although I do like to hear about it, so feel free to use this thread).

About the server connection, nothing really changed in this part except the socket handling. I'll check it out.

#16 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7670
  • Joined: 20-August 08

Posted 09 August 2013 - 11:44 PM

:thumbup: :thumbup: :thumbup:

I have the same server issue reported by fox88 and riso64bit...

(CryptTCPPaddingLength=234)
With obfuscation disabled, it connects almost immediately.
With obfuscation partially enabled, it shows that behavior, but it connects without obfuscation.
With obfuscation fully enabled, it doesn't connect at all.

I don't know if it's normal, but I can't change the language from English to Italian: it says it is not installed, asking me to download from the website.
I respond yes and it says "Failed to download and install selected language library from hddp://langmirror3.emule-project.org/lang/05015/it_IT.dll!".
IMO, it is strange for sure, given that no string has been changed.

The verbose log shows yet those boring messages "Read IdentifierDesc: 7 - Write IdentifierDesc: 7"

:thumbup: :thumbup: :thumbup:

This post has been edited by xilolee: 11 August 2013 - 09:18 AM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Immagine Postata
0

#17 User is offline   Zangune 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1941
  • Joined: 05-March 12

Posted 10 August 2013 - 07:52 AM

View Postfox88, on 09 August 2013 - 09:27 PM, said:

Server connection behaves oddly in 0.50b.

The same here. It seems too fast to switch to another server to me.

View PostRiso64Bit, on 09 August 2013 - 09:44 PM, said:

Emule try to open "emule.tmpl" under the same folder of eMule.exe but it's not present & "webserver" folder is empty.

eMule.tmpl is in config folder, in webaserver folder there are .gif files and an .ico file.

View Postxilolee, on 10 August 2013 - 01:44 AM, said:

I respond yes and it says "Failed to download and install selected language library from hddp://langmirror3.emule-project.org/lang/05015/it_IT.dll!".

If you click here langmirror3.emule-project.org/lang/05015 you can read

Quote

The requested URL /lang/05015 was not found on this server.

Because nobody translated lang files for eMule 0.50.1.5 also known as eMule 0.50b BETA 3.
In langmirror3 there is not /lang folder.

Quote

ReadCompletetionRoutine: Didn't read requested datacount - wanted: 86448, read: 0
IO Error: GetOverlappedResult: L'evento di I/O sovrapposto non č in uno stato segnalato.

Translation note: second error should be translated as "Overlapped I/O event object not in signaled state".

Both errors causes this

Quote

10/08/2013 9.24.35: Removing client from upload list: IO/Other Error while creating datapacket (see earlier log entries) Client: <omissis> 'http://emule-project.net' (eMule v0.50a,None/Uploading/None) Transferred: 0 secs SessionUp: 0 Bytes QueueSessionPayload: 0 Bytes In buffer: 84.42 KB Req blocks: 0

and 0 upload.
0

#18 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4473
  • Joined: 13-May 07

Posted 10 August 2013 - 09:34 AM

View PostZangune, on 10 August 2013 - 10:52 AM, said:

View PostRiso64Bit, on 09 August 2013 - 09:44 PM, said:

Emule try to open "emule.tmpl" under the same folder of eMule.exe but it's not present

eMule.tmpl is in config folder

No.
Path to template file is defined in preferences.ini
0

#19 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4473
  • Joined: 13-May 07

Posted 10 August 2013 - 09:59 AM

View PostSome Support, on 09 August 2013 - 11:43 PM, said:

No, it's not a Beta yet.

The log says:
10/08/2013 03:06:43: eMule Version 0.50b BETA3 ready

You could implement ALPHA string for that case.


CPU usage question.

Started eMule and connected to both networks. There are no files to download and no new files to hash, except beta-specific one, of course.
Publishing in KAD should not use much, and there is enough RAM for eMule.
Mostly process explorer shows 1-2% of CPU usage, but I saw frequent spikes to double-digit numbers, and once it was 22%. Which appears to be too high for an idling application.
What could be causing such bursts of required processor power?
Now eMule uploads at ~1MB/s, CPU usage is 5-10% most of the time, and below 15% in the worst case I spotted.

This post has been edited by fox88: 08 March 2015 - 09:26 PM

0

#20 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4473
  • Joined: 13-May 07

Posted 10 August 2013 - 11:50 AM

Crash dump.
0

  • Member Options

  • (27 Pages)
  • +
  • 1
  • 2
  • 3
  • Last »

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users