Official eMule-Board: Emule Morph 0.49c 11.2 [23-03-2009] - Official eMule-Board

Jump to content


  • (4 Pages)
  • +
  • 1
  • 2
  • 3
  • 4

Emule Morph 0.49c 11.2 [23-03-2009] merged to 0.49c with a huge changelog

#41 User is offline   gnome 

  • Member
  • PipPip
  • Group: Validating
  • Posts: 35
  • Joined: 15-October 02

Posted 25 March 2009 - 12:14 PM

Danke / thank / merci :+1:
In a world without walls and fences - who needs Windows and Gates?
0

#42 User is offline   Alabanda 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 07-December 07

Posted 25 March 2009 - 04:04 PM

Thanks to all those who made this happen, really appreciated! :D
0

#43 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 27 March 2009 - 10:03 PM

small note for the guys who think it is cool to publish our sources unpermittedly: you are even pathetic when fixing bugs. it amazes me how somebody can just fail so bad. now, it may be my error to do a little too much C&P while working and not paying enough attention then but when you need to change 2 lines when i just need to remove a single char... wow, you are greatness... (pause) ...NOT!
#ifndef NO_HISTORY
						pEd2kType->m_htItem = InsertItem(TVIF_TEXT | TVIF_PARAM | TVIF_IMAGE | TVIF_SELECTEDIMAGE, GetResString(_aEd2kTypeView[i].uStringId), i+6, i+6, 0, 0, (LPARAM)pEd2kType, pCurrent->m_htItem, TVI_LAST);

should of course be:
#ifdef NO_HISTORY

note that i did not check your solution until now but fixed this bug on the train earlier today.

about beta software, it is not up to you if there is any beta of the software the morphteam produces or not. we do whatever we see fit to meet the MorphXT standards but releasing code you know no details about under the same name is not exactly helping us keeping the reputation morph got. if somebody feels like using untested code he should get it done himself. releasing bins for us is not an option!
Posted Image

This post has been edited by Stulle: 27 March 2009 - 10:05 PM

I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#44 User is offline   Kurdt 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 28-March 09

Posted 28 March 2009 - 01:48 PM

Hi, this is my first message here.

I updated to MorphXT 11.2 and when I try to run it, I get the following message:

The procedure entry point FreeAddrInfoW could not be located in the dynamic link library WS2_32.dll

I use Windows XP SP1. Is there any solution for my problem?

Thanks.

I'm sorry if this is not the right thread to post my problem.

Greetings from Spain.
0

#45 User is offline   omeringen 

  • l÷l
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 983
  • Joined: 01-January 06

Posted 28 March 2009 - 02:54 PM

@Kurdt,
You need at least SP2 AFAIK.(SP3 released you know)
0

#46 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 29 March 2009 - 03:17 PM

yes, to make this official, due to the usage of VS05 and Vista SDK you are required to use XP SP2 or above. for the time being i think there will be no special support for older OS' because they are simply too old. not using VS05 means loosing some valuable advantages and thus do i think it is time we move on.
I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#47 User is offline   Rabiator.MMT 

  • Member
  • PipPip
  • Group: Members
  • Posts: 17
  • Joined: 10-March 07

Posted 30 March 2009 - 05:19 AM

Posted Image

:confused:

It shows 107.5%?! WTF!

The other client uses AnalyZZUL 3.0.
0

#48 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 30 March 2009 - 06:01 AM

in fact, this is a known bug but we did not look into it, it appears.
I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#49 User is offline   vairo 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 17-March 04

Posted 30 March 2009 - 05:40 PM

After upgrade from 11.1 to 11.2 the download speed has become low.
So I downgrade to 11.1 and the speed returned high

This post has been edited by vairo: 30 March 2009 - 05:41 PM

0

#50 User is offline   leexgx 

  • UK MAD FOR LESS
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 2533
  • Joined: 04-November 02

Posted 31 March 2009 - 08:54 PM

guess its time to reset me emule not done it for around 1-2 years

(i should allso update my sig now)

This post has been edited by leexgx: 31 March 2009 - 08:55 PM

in and around
0

#51 User is offline   Calibra 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 122
  • Joined: 22-July 04

Posted 03 April 2009 - 07:57 PM

Mee to, stil on 9.4. But i will do a fresh install soon.

Great that you people still continue the development.

Great!!! :respect: :respect: :respect:

This post has been edited by Calibra: 03 April 2009 - 07:59 PM

[sun-shares.com] Calibra
0

#52 User is offline   tHeWiZaRdOfDoS 

  • Man, what a bunch of jokers...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5630
  • Joined: 28-December 02

Posted 05 April 2009 - 10:42 AM

A minor thing:

Quote

AddClientToQueue(cur_client,true,keepWaitingTime); // we want bIgnoreTimelimit parameter to be true!

There surely is something wrong... you might have wanted to replace 'keepWaitingTime' by 'true' - but that way it might cause trouble.
Also, the mule_vista icon is missing (the official one is in the res folder).


Now to something completely different: I have something for the ppl using Win2K :flowers:
I compiled a Morph version with V$ 2003 SP1 which should "fix" the mentioned error. There is no startup sound and maybe some things won't work as intended as the Morph Team moved to V$ 2005 and dropped the support but WTH... I just wanted to give you a toy to play with :woot:
So, if you feel like you want to test it, here's a DL link for you: click

Have fun,
WiZ
0

#53 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 05 April 2009 - 10:48 AM

hmmm, i was wondering about this... i will have to review this... might that be the reason for the queue bug after all... anyway, thanks for pointing it out. i did not spend too much time looking into that...

about the vs03 build, i am not asking you to remove it but i want anybody to know that this build is entirely unsupported from the official staff. i will consider making an official vs03 build for the next version but this has not been decided, yet.
I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#54 User is offline   tHeWiZaRdOfDoS 

  • Man, what a bunch of jokers...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5630
  • Joined: 28-December 02

Posted 05 April 2009 - 10:57 AM

No offense meant or felt - I just thought that it's a pity that some MorphXT fans have to use an old version or move to another one so I did this quick compile.
If you do not want to make that V$ 2003 build then you could simply send me the srcs and I'd compile them for you - no problem :flowers:
0

#55 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 05 April 2009 - 11:03 AM

i got VS03 installed on both of my mashines so it is not the lack of vs03 that is hindering me. it is much rather the uncertainty if we should keep supporting this fairly old OS. MS product politics may not be the nicest all the time but imo there are reasons for new version of any product and supporting old products indefinatly is not desireable. another problem is that none of the crew got Win2k running so it will be hard for us to track down OS specific probems.

anyway, this has yet to be decided.
I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#56 User is offline   James R. Bath 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 790
  • Joined: 02-August 04

Posted 05 April 2009 - 07:37 PM

View Postxscarab, on Mar 24 2009, 01:10 PM, said:

How long have the icons been wrong? before 49b? or is that when they first got mixed up.? :worthy:

I have 49b/11.1 up and it's wrong there ... and ... a quick run of 49a/11.0 shows wrong there too. Not that I care. Just filling in for the incompetent testers. :P I never use the category/grouping things anyway. Maybe the next easteregg can be various body parts replacing those icons.
Currently recommending and using: eMule beba 2.63
For slot control only, currently recommending: Tombstone Xtended 1.0 (or higher) if you absolutely must have slot control


Posted Image

Quote

Where there is a mule there is fuel. Where there is a stool sits a fool. - Winston Churchill

0

#57 User is offline   James R. Bath 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 790
  • Joined: 02-August 04

Posted 05 April 2009 - 07:59 PM

View PostStulle, on Apr 5 2009, 10:48 AM, said:

hmmm, i was wondering about this... i will have to review this... might that be the reason for the queue bug after all... anyway, thanks for pointing it out. i did not spend too much time looking into that...

I'm not having any immediate queue/UL/DL problems after doing a quick switch from 11.1 to 11.2. I'm using the same IP and ports and the time Morph was closed/disconnected was under 5 minutes. Over 1000 within 10 minutes (at around 3000 when closed). I'd still like an option for remembering the banned between closes.
Currently recommending and using: eMule beba 2.63
For slot control only, currently recommending: Tombstone Xtended 1.0 (or higher) if you absolutely must have slot control


Posted Image

Quote

Where there is a mule there is fuel. Where there is a stool sits a fool. - Winston Churchill

0

#58 User is offline   Andu 

  • Morph Team
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 13015
  • Joined: 04-December 02

Posted 05 April 2009 - 08:00 PM

Pffffft maybe we should make you a tester so that we may mock you too :P
Three Rings for the Elven-kings under the sky,
Seven for the Dwarf-lords in their halls of stone,
Nine for Mortal Men doomed to die,
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the Land of Mordor where the Shadows lie.


Dark Lord of the Forum


Morph your Mule

Need a little help with your MorphXT? Click here

0

#59 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5800
  • Joined: 07-April 04

Posted 05 April 2009 - 10:06 PM

View PostJames R. Bath, on Apr 5 2009, 07:59 PM, said:

View PostStulle, on Apr 5 2009, 10:48 AM, said:

hmmm, i was wondering about this... i will have to review this... might that be the reason for the queue bug after all... anyway, thanks for pointing it out. i did not spend too much time looking into that...

I'm not having any immediate queue/UL/DL problems after doing a quick switch from 11.1 to 11.2. I'm using the same IP and ports and the time Morph was closed/disconnected was under 5 minutes. Over 1000 within 10 minutes (at around 3000 when closed). I'd still like an option for remembering the banned between closes.

well, it appears there was no bug after all... an bugfix had to be fixed because it was applied improperly first but the current one matches ZZUL code which made this fix neccessary in the first place.

anyway, two friendly reminders: firstly, nobody is restricting feedback to the testers so if the testers are too incompetent to tell me it is safe to assume that 99% of the morph users are too incompetent, too. second reminder, there is a edit button and it was not created because somebody loved the view of the button in the layout...

View PostAndu, on Apr 5 2009, 08:00 PM, said:

Pffffft maybe we should make you a tester so that we may mock you too :P

maybe we should wait for those smart asses releasing internal builds without permission to tell us about all bugs and how to fix them... apparently they know a lot more about the production of the morphxt mod than we do... what do you say?
I am an emule-web.de member and fan!

[Imagine there was a sarcasm meter right here!]

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#60 User is offline   Andu 

  • Morph Team
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 13015
  • Joined: 04-December 02

Posted 05 April 2009 - 10:11 PM

Works for me :-k
Three Rings for the Elven-kings under the sky,
Seven for the Dwarf-lords in their halls of stone,
Nine for Mortal Men doomed to die,
One for the Dark Lord on his dark throne
In the Land of Mordor where the Shadows lie.
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the Land of Mordor where the Shadows lie.


Dark Lord of the Forum


Morph your Mule

Need a little help with your MorphXT? Click here

0

  • Member Options

  • (4 Pages)
  • +
  • 1
  • 2
  • 3
  • 4

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users