Official eMule-Board: Latest Version: Zzul 20090222-2320 (emule 0.49c) - Official eMule-Board

Jump to content


  • (3 Pages)
  • +
  • 1
  • 2
  • 3

Latest Version: Zzul 20090222-2320 (emule 0.49c) First version based on 0.49c

#21 User is offline   zz 

  • -
  • PipPipPipPipPipPipPip
  • Group: Debugger
  • Posts: 2014
  • Joined: 30-November 02

Posted 12 March 2009 - 01:24 AM

Wouldn't surprise me if there's some problems in those sections. I had to do some hand-merging when it comes to the sorting, and in the first run I missed 3 entire sections. I thought I had catched all the mistakes, but apparently not.

I can probably find the sort-error above quickly, but if someone does it before me, a post of the code would be great. Means less work for me, after all :D

/zz B)
ZZUL - get control of your uploads: ZZUL Forum
0

#22 User is offline   zz 

  • -
  • PipPipPipPipPipPipPip
  • Group: Debugger
  • Posts: 2014
  • Joined: 30-November 02

Posted 12 March 2009 - 01:34 AM

Quick update for any mergers: Moving the break; at SharedFilesCtrl.cpp:1452 to the end of that section fixes the sorting problem for the upload prio column.

I'll release fixed code and fixed exe eventually, depending on any other bugs we might find.

Not sure about the error report that it doesn't care about the upload file priorities when uploading. Can anyone confirm this? For my upload tests it seemed to work as it should.

I'd also appreciate if someone would check sorting for the other columns where there are other ZZUL features, in the other lists. I think I tested all the columns I added, but some columns have slightly changed behavior in ZZUL compared to official, such as sorting the Powershare levels in the upload prio column in the Shared Files list. If someone could test sorting generally, that would be great.

/zz B)

This post has been edited by zz: 12 March 2009 - 01:40 AM

ZZUL - get control of your uploads: ZZUL Forum
0

#23 User is offline   jerryBG 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 79
  • Joined: 30-December 08

Posted 12 March 2009 - 05:25 PM

when compiling (VS2008) sources of

eMule v0.49c ZZUL 20090222-2320

you encounter error message

Error C2600: (function) : cannot define a compiler-generated special member function (must be declared in the class first)

related to file \srchybrid\UploadPacketCreaterThread.cpp

http://www.errorbase..._class_first%29
http://msdn.microsof...y/cd577fyk.aspx


open header file
UploadPacketCreaterThread.h
search for
class PackedPacketParameters :
	public StandardPacketParameters
{
	public:
		PackedPacketParameters(CUpDownClient* owner, byte* data, UINT togo, const uchar* FileID, uint64 StartOffset, uint64 EndOffset, bool bFromPF, UINT packetSplitSize);

		virtual void CreateAndSend();

};


and change to
class PackedPacketParameters :
	public StandardPacketParameters
{
	public:
		PackedPacketParameters(CUpDownClient* owner, byte* data, UINT togo, const uchar* FileID, uint64 StartOffset, uint64 EndOffset, bool bFromPF, UINT packetSplitSize);

		virtual void CreateAndSend();

	public:
		PackedPacketParameters::~PackedPacketParameters();
};


hope it helps :)
0

#24 User is offline   PetitMinou 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 08-March 09

Posted 12 March 2009 - 05:50 PM

Hey ZZ,

Let me remind you the sorting list bug appeared to me after running ZZUL at the second time, unless I didn't noticed it at the fisrt one.

I can't be totally sure, but as far as I remember it had been running several hours and there was none of my powershared files in the UL list.

I'm just a regular user with no fixing skills but I should try a new fixed version as soon as you release it.
0

#25 User is offline   pesti@eMF 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 171
  • Joined: 28-February 05

Posted 04 April 2009 - 10:29 AM

Download link today added at eMuleFuture.

Download @ eMuleFuture :flowers:
Medion Akoya MD 96380
Intel Core 2 Duo CPU T5450 // 1,67 GHZ // 2048 MB DDR RAM // 256 MB Nvidia GeForce 8600 M GS
Vista Home Premium // ADSL2+ 16000 / 1024

0

#26 User is offline   taz-me 

  • I'm taz (a modder)
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 587
  • Joined: 07-December 06

Posted 04 April 2009 - 02:03 PM

View PostjerryBG, on Mar 12 2009, 07:25 PM, said:

...
and change to
class PackedPacketParameters :
	public StandardPacketParameters
{
	public:
		PackedPacketParameters(CUpDownClient* owner, byte* data, UINT togo, const uchar* FileID, uint64 StartOffset, uint64 EndOffset, bool bFromPF, UINT packetSplitSize);

		virtual void CreateAndSend();

	public:
		PackedPacketParameters::~PackedPacketParameters();
};


hope it helps :)



10'x - however it would be cleaner like :

class PackedPacketParameters :
	public StandardPacketParameters
{
	public:
		PackedPacketParameters(CUpDownClient* owner, byte* data, UINT togo, const uchar* FileID, uint64 StartOffset, uint64 EndOffset, bool bFromPF, UINT packetSplitSize);

		virtual void CreateAndSend();

		~PackedPacketParameters();
};

P2P is about sharing, ed2k is my choice !
0

#27 User is offline   tHeWiZaRdOfDoS 

  • Man, what a bunch of jokers...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5630
  • Joined: 28-December 02

Posted 04 April 2009 - 05:39 PM

ZZ code is known to be efficient but never clean and/or beautiful... :lol:
0

#28 User is offline   jerryBG 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 79
  • Joined: 30-December 08

Posted 04 April 2009 - 06:44 PM

View Posttaz-me, on Apr 4 2009, 04:03 PM, said:

***
10'x - however it would be cleaner like :

class PackedPacketParameters :
	public StandardPacketParameters
{
	public:
		PackedPacketParameters(CUpDownClient* owner, byte* data, UINT togo, const uchar* FileID, uint64 StartOffset, uint64 EndOffset, bool bFromPF, UINT packetSplitSize);

		virtual void CreateAndSend();

		~PackedPacketParameters();
};


then one 10'x back :flowers:
0

#29 User is offline   pesti@eMF 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 171
  • Joined: 28-February 05

Posted 25 April 2009 - 03:07 PM

Maybe a small bug in the following situation where a client want from me two files and I have these files on powershare release voted. The first file, he gets quite normal, but once he has finished the first file and the second file starts, shows me my AnalyZZUL only the "chunk detail bar" and "already parts preserved bar" in green on. The chunk detail bar looks optically then he goes back and forward as if he will "overwriting" or would double upload.

Here you can see a little short movie, like it looks. Please take a look. :-)

Short movie
Medion Akoya MD 96380
Intel Core 2 Duo CPU T5450 // 1,67 GHZ // 2048 MB DDR RAM // 256 MB Nvidia GeForce 8600 M GS
Vista Home Premium // ADSL2+ 16000 / 1024

0

#30 User is offline   tesyoo 

  • Member
  • PipPip
  • Group: Members
  • Posts: 27
  • Joined: 12-August 09

Posted 20 August 2009 - 08:33 AM

how to set the slotfocus thing?
i already have a emule and it downloading thing half way how to combine them?
0

#31 User is offline   CiccioBastardo 

  • Doomsday Executor
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 5541
  • Joined: 22-November 03

Posted 21 August 2009 - 09:50 PM

The slotfocus is automatic and always enabled. To make it work correctly you have to set the upload limit in options->connection.
To continue to download the same files as the old client, the most simple way is to rename the old client (emule.exe in something as emule_old.exe) and copy the executable of this mod in the same directory (with the name emule.exe).
The other method is to set the same temp directory (or directories) in the directories configuration panel of this mod. Do not make both client run at the same time, though.
The problem is not the client, it's the user
0

#32 User is offline   tHeWiZaRdOfDoS 

  • Man, what a bunch of jokers...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5630
  • Joined: 28-December 02

Posted 02 October 2009 - 06:43 AM

Hi ZZ!

I was asked to create a releaser mod based upon ZZUL and so I did... however, the users experienced some crashes and I want to report them to you:

1)

Quote

emule.exe!CPartFile::IsComplete(unsigned __int64 start=482754560, unsigned __int64 end=482938879, bool bIgnoreBufferedData=true) Zeile 1779 C++
emule.exe!UploadDiskreaderThread::CreateNextBlockPackage() Zeile 307 + 0x2f C++
emule.exe!UploadDiskreaderThread::RunInternal() Zeile 143 C++
emule.exe!_AfxThreadEntry(void * pParam=0x002f8918) Zeile 114 + 0x5 C++
emule.exe!_threadstartex(void * ptd=0x080c22b8) Zeile 241 + 0x6 C
kernel32.dll!7718e4a5()

This crashed here:

Quote

if (bIgnoreBufferedData){
for (POSITION pos = m_BufferedData_list.GetHeadPosition();pos != 0;)
{
const PartFileBufferedData* cur_gap = m_BufferedData_list.GetNext(pos);
if ( (cur_gap->start >= start && cur_gap->end <= end)
|| (cur_gap->start >= start && cur_gap->start <= end)
|| (cur_gap->end <= end && cur_gap->end >= start)
|| (start >= cur_gap->start && end <= cur_gap->end)
>>>>>> ) // should be equal to if (start <= cur_gap->end && end >= cur_gap->start)
{
return false;
}
}
}
return true;
}

and that's most likely because you are accessing lists from within another thread - they probably changed while the thread was running... maybe you should adapt SiRoBs solution of upload threading (i.e. NOT moving such "critical" parts into the thread itself).



2)

Quote

ntdll.dll!7c920a19()
emule.exe!CCriticalSection::Unlock() Zeile 83 + 0xa C++
emule.exe!CEMSocket::SendPacket(Packet * packet=0x09d0febc, bool delpacket=true, bool controlpacket=true, unsigned int actualPayloadSize=31129600, bool bForceImmediateSend=false) Zeile 543 C++
emule.exe!CFile::~CFile() Zeile 89 + 0xb C++

This crashed here:

Quote

>>>>>> sendLocker.Unlock();

if (bForceImmediateSend){

I have no idea about that but it seems to occurs randomly, even in official clients.
Maybe this helps a bit and you can solve the issues.

Best regards,
WiZ
0

#33 User is offline   zz 

  • -
  • PipPipPipPipPipPipPip
  • Group: Debugger
  • Posts: 2014
  • Joined: 30-November 02

Posted 07 October 2009 - 09:52 PM

Yes, there are some things that needs to be thread-safed. The threaded uploading is work in (stalled) progress. I've never actually seen it crash before, but the potential for it is certainly there for race conditions. Thanks for the report.
ZZUL - get control of your uploads: ZZUL Forum
0

#34 User is offline   Enig123 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 502
  • Joined: 22-November 04

Posted 08 October 2009 - 12:10 AM

WiZaRd & zz, is there any suggested fix for the latter one that may also affect official client?
0

#35 User is offline   dev84 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 110
  • Joined: 26-May 06

Posted 16 December 2009 - 09:12 AM

Hi, is it possible to add function to manually specify starting TTL for USS for zzul?

I have asked for this in official for a long time, Morph has it but Morph tends to crash.

It would be a good thing for zzul users who have no ping responsive border routers.




Thx

dev


áá
0

#36 User is offline   Lupissimo 

  • Member
  • PipPip
  • Group: Members
  • Posts: 16
  • Joined: 26-December 02

Posted 30 December 2009 - 05:44 PM

I have been using this ZZUL mod from the start under WinXP until now and have recently switched to windows 7. Today I noticed that I can no longer assign a Friend Slot anymore even though the friends have High-ID and use KAD and server and the identification is successful.

Does anybody have an idea how to solve this problem???

Lupissimo

This post has been edited by Lupissimo: 30 December 2009 - 05:45 PM

0

#37 User is offline   xssgssx 

  • Member
  • PipPip
  • Group: Members
  • Posts: 22
  • Joined: 22-June 05

Posted 16 May 2010 - 05:04 PM

View PostMadlyMad, on 22 February 2009 - 07:48 PM, said:

Hi zz

Thanks a lot for being so quick and efficient.
Updated and running,
I'll let you know if I see some kind of weird behavior or something.


What kind of feature(s) is touched by the missing files ?


Cheers ! :beer:


i'm having a slight problem with ZZUL 49c

i keep losing my upload and download rates

i'm running at 250+ kbps uploads and high download rates (when using downloads) and check back and it's dropped to 1 or 2 kbps or some small rate.
i go into the wizard again and reset to my desired settings and they go right back up to where they were before.

like to say some cause, but it's puzzling to me. it has to the the ZZUL client itself, because i have no such problems with emule standard

wonder if there is an explaination for the behavior and is anyone else experiencing it?

thanks

i still like ZZUL for it's power sharing features

:thumbup:

thanks
0

#38 User is offline   coluche 

  • hm ?
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 2274
  • Joined: 02-May 05

Posted 16 May 2010 - 06:20 PM

Do you use USS (Upload Speed Sense) ?

If so try with disabling USS and going by fixed Upload Limit. (80% of capacity?)

You can also try with USS and lower UL limit.

---------
It's Screamin' Jay Hawkins and he's a Wild Man, so bug off!
0

#39 User is offline   xssgssx 

  • Member
  • PipPip
  • Group: Members
  • Posts: 22
  • Joined: 22-June 05

Posted 16 May 2010 - 10:46 PM

View Postcoluche, on 16 May 2010 - 01:20 PM, said:

Do you use USS (Upload Speed Sense) ?

If so try with disabling USS and going by fixed Upload Limit. (80% of capacity?)

You can also try with USS and lower UL limit.

---------


thanks for response

will check into it

cheers

went into advanced settings and saw upload speed sense unchecked

was watching the cue and with a dozen download connects the rates for all but 2 of them went from kbps to bps

with one file at 150 kbps and another at 40 kbps. all the rest were less that 1 kbps

with the less than kp greyed out

checked the find best speed box to see if it made any difference and it did not

any ideas why it's doing that? get nothing like it with emule standard

thanks

This post has been edited by xssgssx: 16 May 2010 - 10:54 PM

0

#40 User is offline   coluche 

  • hm ?
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 2274
  • Joined: 02-May 05

Posted 18 May 2010 - 02:40 PM

hej,

I am not sure if I understand your problem correctly. Maybe a screenshot helps making things clearer ?

Is overall upload speed constant, just the single upload slots that are not having constant speed ?

so long
It's Screamin' Jay Hawkins and he's a Wild Man, so bug off!
0

  • Member Options

  • (3 Pages)
  • +
  • 1
  • 2
  • 3

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users