Official eMule-Board: How To Build Emule 0.49b With Vs 2003 - Official eMule-Board

Jump to content


  • (4 Pages)
  • +
  • 1
  • 2
  • 3
  • 4

How To Build Emule 0.49b With Vs 2003

#21 User is offline   pupet 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 24-November 05

Posted 01 March 2009 - 10:04 PM

problem compile emule v0.49c :

Generating Code...
c:\program files\microsoft visual studio .net 2003\vc7\include\list(923) : warning C4702: unreachable code
Compiling...
MediaInfo.cpp
MediaInfo.cpp(25) : fatal error C1083: Cannot open include file: 'wmsdk.h': No such file or directory

please help
0

#22 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5738
  • Joined: 07-April 04

Posted 01 March 2009 - 11:18 PM

please see the readme file in the official binary package for detailed information on what SDKs and stuff you will need to compile. i suppose you miss the windows media sdk... guessing by the file throwing the error and the name of the missing file.
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#23 User is offline   zz 

  • -
  • PipPipPipPipPipPipPip
  • Group: Debugger
  • Posts: 2014
  • Joined: 30-November 02

Posted 02 March 2009 - 02:29 AM

I'll make a new thread for 0.49c at some point. For the above problem, there's info in the emule_site_config.h that tells you where to get the windows media SDK.

/zz B)
ZZUL - get control of your uploads: ZZUL Forum
0

#24 User is offline   pupet 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 24-November 05

Posted 03 March 2009 - 08:21 PM

thanks very much ZZ

This post has been edited by pupet: 03 March 2009 - 08:22 PM

0

#25 User is offline   Matrik 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 215
  • Joined: 02-February 04

Posted 04 March 2009 - 08:06 PM

Hi :)

Quote

I'll make a new thread for 0.49c at some point

Thx again zz :thumbup:

I need help:
because I try to compil eMule0.49b with VS2003 7.1 everything is ok but I have this error again :cool2:

Quote

d:\emule sources\002\emule0.49b-sources\srchybrid\webserver.cpp(2435) : fatal error C1001: ERREUR INTERNE DU COMPILATEUR (fichier 'f:\vs70builds\3077\vc\Compiler\Utc\src\P2\main.c', ligne 148)

sorry it's a french VS2003 :-k

thx for your help !!

:respect:
ISSA-NISSA
.:Aqui Finda Sian Nissart:.
0

#26 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5738
  • Joined: 07-April 04

Posted 05 March 2009 - 12:51 AM

it's an internal error... i am just guessing but your development environment might be screwed up. consider reinstalling it... but you may as well do some more researches on the C1001 error before reinstalling.
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#27 User is offline   Matrik 

  • Splendid Member
  • PipPipPipPip
  • Group: Members
  • Posts: 215
  • Joined: 02-February 04

Posted 05 March 2009 - 09:41 PM

hi :mellow:
thx Stulle for your help, I try to reinstall everything !

thx again
:flowers:
ISSA-NISSA
.:Aqui Finda Sian Nissart:.
0

#28 User is offline   bupo 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 26-March 09

Posted 26 March 2009 - 06:16 AM

Is there any other way to get the eMule 0.49b libs , I can't download it using the given link. there is no download speed.
0

#29 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5738
  • Joined: 07-April 04

Posted 26 March 2009 - 09:48 AM

try the source edit from JohnLLLL: eMule0.49b-Sources-JohnLLLL.rar
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#30 User is offline   fox88 

  • Golden eMule
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 4480
  • Joined: 13-May 07

Posted 26 March 2009 - 10:05 AM

Or read topic about 0.49c from taz-me. Unless you have reasons to use 0.49b, of course.

This post has been edited by fox88: 26 March 2009 - 12:24 PM

0

#31 User is offline   pupet 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 24-November 05

Posted 28 March 2009 - 09:24 PM

problem compile optimizer emule amd :

emule.obj : error LNK2001: unresolved external symbol "public: bool __thiscall CPUInfo::DoesCPUSupportFeature(unsigned long)" (?DoesCPUSupportFeature@CPUInfo@@QAE_NK@Z)
emule.obj : error LNK2001: unresolved external symbol "public: __thiscall CPUInfo::CPUInfo(void)" (??0CPUInfo@@QAE@XZ)
emule.obj : error LNK2001: unresolved external symbol "public: __thiscall CPUInfo::~CPUInfo(void)" (??1CPUInfo@@QAE@XZ)
emule.obj : error LNK2001: unresolved external symbol "public: char * __thiscall CPUInfo::GetExtendedProcessorName(void)" (?GetExtendedProcessorName@CPUInfo@@QAEPADXZ)
emule.obj : error LNK2001: unresolved external symbol "unsigned long __cdecl get_cpu_type(void)" (?get_cpu_type@@YAKXZ)
emule.obj : error LNK2001: unresolved external symbol "public: int __thiscall CPUInfo::GetProcessorCacheXSize(unsigned long)" (?GetProcessorCacheXSize@CPUInfo@@QAEHK@Z)
Release/emule.exe : fatal error LNK1120: 6 unresolved externals

emule - 7 error(s), 30 warning(s)


---------------------- Done ----------------------

Build: 0 succeeded, 1 failed, 0 skipped
0

#32 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7694
  • Joined: 20-August 08

Posted 29 March 2009 - 03:03 PM

In options - projects - vc++ directories I had to add "C:\Program files\Microsoft Visual Studio .NET 2003\Vc7\include" (under "Include Files") and "C:\Programmi\Microsoft Visual Studio .NET 2003\Vc7\lib" under "Library Files", otherwise there was numerous errors ...

With 49b sources i have these (final) messages:

------ Build started: Project: emule, Configuration: Release Win32 ------

Linking...
LINK : warning LNK4089: all references to 'comdlg32.dll' discarded by /OPT:REF

Build log was saved at "file://c:\Documents and Settings\davide\Documenti\Documenti\emule\eMule0.49b-Sources\srchybrid\Release\BuildLog.htm"
emule - 0 error(s), 1 warning(s)


---------------------- Done ----------------------

	Build: 8 succeeded, 0 failed, 0 skipped


Anyway, emule0.49b was created! :thumbup:


------------------------------------------------------------------------------------------------------------------------------------------------------------


View Postpupet, on Mar 2 2009, 12:04 AM, said:

problem compile emule v0.49c :

Generating Code...
c:\program files\microsoft visual studio .net 2003\vc7\include\list(923) : warning C4702: unreachable code
Compiling...
MediaInfo.cpp
MediaInfo.cpp(25) : fatal error C1083: Cannot open include file: 'wmsdk.h': No such file or directory

please help


I have the same message with 49c sources ( with the same libs for 0.49b):

------ Build started: Project: emule, Configuration: Release Win32 ------

Compiling...

MediaInfo.cpp
MediaInfo.cpp(25) : fatal error C1083: Cannot open include file: 'wmsdk.h': No such file or directory

Build log was saved at "file://c:\Documents and Settings\davide\Documenti\Documenti\emule\eMule0.49c-Sources\srchybrid\Release\BuildLog.htm"
emule - 1 error(s), 0 warning(s)


---------------------- Done ----------------------

	Build: 7 succeeded, 1 failed, 0 skipped



I tried installing WMFSDK9 and putting in options - projects - vc++ directories "C:\Programmi\WMSDK\WMFSDK9\include" (under "Include Files"), and "C:\Programmi\WMSDK\WMFSDK9\lib" under "Library Files" ... And finally i made it !!!

(Before i was trying with WMFSDK11 and WMFSDK95 without success :ranting: )

Thanks ZZ :D

This post has been edited by xilolee: 30 March 2009 - 01:03 AM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Posted Image
0

#33 User is offline   linux_rodo 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 07-January 03

Posted 01 April 2009 - 03:04 PM

:worthy: xilolee says :

Quote

I tried installing WMFSDK9 and putting in options - projects - vc++ directories "C:\Programmi\WMSDK\WMFSDK9\include" (under "Include Files"), and "C:\Programmi\WMSDK\WMFSDK9\lib" under "Library Files" ... And finally i made it !!!


YES THAT IS THE RIGTH WAY TO DO IT!

I was trying without success compiling until that I read your post.

Your suggest must to be included in the "official compiling post"

MANY THANX
0

#34 User is offline   xilolee 

  • eMule 0.50b BETA1 user
  • PipPipPipPipPipPipPip
  • Group: Italian Moderators
  • Posts: 7694
  • Joined: 20-August 08

Posted 02 April 2009 - 08:21 PM

@linux_rodo
The suggestion is by Stulle and ZZ :D

These steps should work to compile the 49c version:
1) download and install speech api (only if it is not installed yet) then go to Visual Studio Menu->Tools->Options, Chose Projects->"VC++ Directories" and add "C:\Program Files\Microsoft Speech SDK 5.1\Include" (under "Include Files") and "C:\Program Files\Microsoft Speech SDK 5.1\Lib\i386" (under "Library Files")
2) download and install WMFSDK9 (only if it is not installed yet) and put in tools - options - projects - vc++ directories "C:\Programmi\WMSDK\WMFSDK9\include" (under "Include Files"), and "C:\Programmi\WMSDK\WMFSDK9\lib" (under "Library Files")
3) download and unpack emule0.49c- sources
4) download and unpack the eMule 0.49b libs archive (cryptopp 5.1, resizablelib 1.3, zlib 1.2.3, libpng ?.?.?):
ed2k://|file|eMule-0.49b-libs.zip|1732292|0D1C22554DD88A11883D73B3624D929D|/
5) open the folder 0.49b libs, open the zlib folder, delete emule_vc71.sln and emule_vc71.vcproj, then copy-paste all the folders (crypto51, libpng, resizablelib, zlib) in the 49c-sources folder
6) open the emule_vc71-all.sln in the srchybrid folder and build the emule_vc71-all.sln in release mode

And we will see these warnings:

Quote

------ Build started: Project: ReplaceVistaIcon, Configuration: Release Win32 ------
...
LINK : warning LNK4089: all references to 'USER32.dll' discarded by /OPT:REF
...
------ Build started: Project: CxImage, Configuration: Release Win32 ------
...
ximapng.cpp(480) : warning C4101: 'c' : unreferenced local variable
ximaint.cpp(404) : warning C4101: 'pxptra' : unreferenced local variable
ximaint.cpp(486) : warning C4101: 'pxptra' : unreferenced local variable
...
------ Build started: Project: emule, Configuration: Release Win32 ------
106 warnings like the two following
c:\prog\ms visual studio .net 2003\vc7\include\list(923) : warning C4702: unreachable code
c:\prog\ms visual studio .net 2003\vc7\include\xtree(1116) : warning C4702: unreachable code
...
LINK : warning LNK4089: all references to 'comdlg32.dll' discarded by /OPT:REF
...

Waiting for someone with more skill for confirmation ... :confused:

(I have xp home edition 5.1.2600 sp3 build 2600 and IDE 7.1.3088 (2003) with .NET F. 1.1.4322 sp1)
I obtain an emule.exe (release) of 5 656 576 bytes / 5 524 kB instead of 5 668 864 bytes / 5 536 kB
For debug: 11720 kB / 12 001 280 bytes instead of 11 724 kB (?) / 12 005 376 bytes

I found that different optimizations (configuration properties, c/c++, optimization) create different sizes.
It works also with the last version of libpng (1.2.37).

To avoid the warnings in the cximage, i modified the files in this way:
line 480 of ximapng.cpp: /* original: RGBQUAD c; */ /* modified: */ RGBQUAD c; c = BlindGetPixelColor(0,0);
lines 404 and 486 of ximaint.cpp: /* original: BYTE *pxptr, *pxptra; */ /* modified: */ BYTE *pxptr;

To avoid the warnings in emule, i modified the stdafx.h in this way (thanks Stulle!):
line 121, inserted/added: #pragma warning(disable:4702) // unreachable code

Did I make some damage? :D

Now, only 2 warnings remain:

Quote

------ Build started: Project: ReplaceVistaIcon, Configuration: Release Win32 ------
...
LINK : warning LNK4089: all references to 'USER32.dll' discarded by /OPT:REF
...
------ Build started: Project: emule, Configuration: Release Win32 ------
...
WINVER not defined. Defaulting to 0x0501 (Windows XP and Windows .NET Server) ...
LINK : warning LNK4089: all references to 'comdlg32.dll' discarded by /OPT:REF
...


WINVER isn't a warning, but it makes suspicions in me... :huh:

This post has been edited by xilolee: 17 August 2009 - 07:39 PM

INCONCEIVABLE! - You keep using that word. I do not think it means what you think it means.
come ottenere aiuto italian guides - guide della sezione italiana
italian support - sezione italiana scaricare la lista server
ottenere id alto impostare le porte nel router
recuperare file corrotti i filtri ip
Sembra talco ma non č serve a darti l'allegrIa! Se lo lanci e poi lo respiri ti dā subito l'allegrIa! Posted Image
0

#35 User is offline   moloko+ 

  • ...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1209
  • Joined: 18-August 05

Posted 12 April 2009 - 08:47 PM

View Postxilolee, on Apr 3 2009, 06:21 AM, said:

Waiting for someone with more skill for confirmation ... :confused:


Heh, I'm not sure that I am that person :unsure: , but these warnings...

ximapng.cpp(480) : warning C4101: 'c' : unreferenced local variable
ximaint.cpp(404) : warning C4101: 'pxptra' : unreferenced local variable
ximaint.cpp(486) : warning C4101: 'pxptra' : unreferenced local variable


...are just warnings that a parameter isn't referred to in the scope of the function.

You could use this macro, inside the function, to avoid seeing that warning, but it's not necessary.

UNREFERENCED_PARAMETER( c );
UNREFERENCED_PARAMETER( pxptra );

The other warnings are similar, and you can use a #pragma directive (look in the VS help) to turn off/on the warnings (C4702), but again it's not really necessary, it's feedback.

If it compiled then :thumbup: !

Hope that helps.
0

#36 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5738
  • Joined: 07-April 04

Posted 13 April 2009 - 08:12 AM

well, check out the stdafx.h and search for disable. this will show you how to disable warnings. get to the end and add the corresponding lines to disable the warnings you want to get rid of.

actually, C4702 is disabled and then re-enabled for some odd reason... no idea why it is done this way but w/e...
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#37 User is offline   moloko+ 

  • ...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1209
  • Joined: 18-August 05

Posted 14 April 2009 - 06:05 AM

(yikes, I was logged on overnight, oops)

You only need to build the solutions for the libraries once, well twice, in the Debug and Release versions. After that, use the emule_vc71.sln. Don't need to touch the library code unless you know what you are doing.

The size of the executable might vary depending on the libraries you use (versions), but they should be fairly close if not exact if everything is the same as the dev's developing environment (I think!).

Have fun!

--"actually, C4702 is disabled and then re-enabled for some odd reason... no idea why it is done this way but w/e..."

Hey Stulle.

Maybe too many warnings in the output window. don't know.
0

#38 User is offline   Rapid_Mule 

  • "routing problems on the neural net"
  • PipPipPipPipPip
  • Group: Members
  • Posts: 256
  • Joined: 03-May 04

Posted 14 April 2009 - 11:18 AM

View PostStulle, on Apr 13 2009, 11:12 AM, said:

well, check out the stdafx.h and search for disable. this will show you how to disable warnings. get to the end and add the corresponding lines to disable the warnings you want to get rid of.

actually, C4702 is disabled and then re-enabled for some odd reason... no idea why it is done this way but w/e...

I'm not sure, but it might be related to "/Wall" in the command line.
0

#39 User is offline   moloko+ 

  • ...
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 1209
  • Joined: 18-August 05

Posted 14 April 2009 - 10:00 PM

View Postxilolee, on Apr 15 2009, 06:30 AM, said:

View Postmoloko+, on Apr 14 2009, 08:05 AM, said:

You only need to build the solutions for the libraries once, well twice, in the Debug and Release versions. After that, use the emule_vc71.sln.

Same result ... debug version is 11720 kB :ph34r:


Here are my exe sizes, (no mods):

12,005,376 bytes > Debug

5,668,864 bytes > Release

I imagine it's OS, SDK and dev environment related, which will be slightly different, but maybe someone else can shed some light on this.

I don't think it's too critical, so long as it compiles okay.
0

#40 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5738
  • Joined: 07-April 04

Posted 15 April 2009 - 03:26 PM

View Postmoloko+, on Apr 14 2009, 10:00 PM, said:

View Postxilolee, on Apr 15 2009, 06:30 AM, said:

View Postmoloko+, on Apr 14 2009, 08:05 AM, said:

You only need to build the solutions for the libraries once, well twice, in the Debug and Release versions. After that, use the emule_vc71.sln.

Same result ... debug version is 11720 kB :ph34r:


Here are my exe sizes, (no mods):

12,005,376 bytes > Debug

5,668,864 bytes > Release

I imagine it's OS, SDK and dev environment related, which will be slightly different, but maybe someone else can shed some light on this.

I don't think it's too critical, so long as it compiles okay.

just changing > to < in the code or add a single log line will result in different file sizes, iirc. so no point in comparing this kinda stuff...
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

  • Member Options

  • (4 Pages)
  • +
  • 1
  • 2
  • 3
  • 4

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users