Official eMule-Board: Impossible To Compile Mephisto 3.0 With Vs2008 - Official eMule-Board

Jump to content


Page 1 of 1

Impossible To Compile Mephisto 3.0 With Vs2008 Two main errors in EMSocket.

#1 User is offline   giquem 

  • Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: 10-May 14

Posted 28 May 2014 - 03:21 PM

Hellow Stulle:
I try to compile this mod but I was unable to do it. Always the same errors. All is good until the moment in wich VS2008 generate the emule.exe. I put the latest lines of the BuildLog:

Vinculando...
Creando biblioteca .\release\eMule.lib y objeto .\release\eMule.exp
EMSocket.obj : error LNK2001: símbolo externo "public: unsigned long __thiscall CNetF::GetMSSFromSocket(unsigned int)" (?GetMSSFromSocket@CNetF@@QAEKI@Z) sin resolver
EMSocket.obj : error LNK2001: símbolo externo "class CNetF theNetF" (?theNetF@@3VCNetF@@A) sin resolver
.\release\eMule.exe : fatal error LNK1120: 2 externos sin resolver

I have tried all, including to modify the EMSocket.cpp in a way that you say in another post from 2013. Something is wrong in the source code (I have downloaded it from the Mephisto Homepage), or may be it is my fault? Thanks in advance for your time.
0

#2 User is offline   giquem 

  • Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: 10-May 14

Posted 06 June 2014 - 01:42 PM

I tried to compile Scarangel and I have found the same errors.
Finally, I've found the solution alone.
I used Emule90.sln to compile with VS2008, as the instructions say, but it was impossible to compile Scarangel or Mephisto. I tried to use emule80.sln, and VS 2008 told me that it was necessary to convert the file to a newer version of Visual Studio. I let the program do it ... and that was the solution. So, it should compile with emule80.
If this can help someone...
0

#3 User is offline   pupet 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 24-November 05

Posted 07 June 2014 - 12:43 PM

thank you very much for the solution:
0

#4 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5,738
  • Joined: 07-April 04

Posted 15 June 2014 - 11:48 AM

The problem is that the solution file for VS08 did not contain the NetF.cpp. Hence, the file was not compiled and could not be linked. This is the error you see. Just add the NetF.cpp to the emule90 solution and it should work fine. No idea how that bit got lost but I have not been using VS08 for a long time but focussed on VS10 instead.
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

#5 User is offline   giquem 

  • Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: 10-May 14

Posted 25 June 2014 - 02:57 PM

View PostStulle, on 15 June 2014 - 12:48 PM, said:

The problem is that the solution file for VS08 did not contain the NetF.cpp. Hence, the file was not compiled and could not be linked. This is the error you see. Just add the NetF.cpp to the emule90 solution and it should work fine. No idea how that bit got lost but I have not been using VS08 for a long time but focussed on VS10 instead.


OK. I have modified the file "emule90.vcproj" in this way:

The file from the official site of Mephisto:
<File
RelativePath=".\MassRename.h"
>
</File>
<File
RelativePath=".\NumEdit.cpp"
>
</File>

(From line 4265)

The modified file:
<File
RelativePath=".\MassRename.h"
>
</File>
<File
RelativePath=".\NetF.cpp"
>
</File>
<File
RelativePath=".\NetF.h"
>
</File>

<File
RelativePath=".\NumEdit.cpp"
>
</File>

And now emule90.sln works fine and it is possible to compile eMule Mephisto.
I think it will be good if you can modify the file in the source code of this mod. The same for the Scarangel mod, I think (I have not tried it, but probably contains the same error).
Thanks.
0

#6 User is offline   Stulle 

  • [Enter Mod] Dev
  • PipPipPipPipPipPipPip
  • Group: Members
  • Posts: 5,738
  • Joined: 07-April 04

Posted 28 June 2014 - 02:43 PM

This is a very basic and simple to fix error which can be fixed by anyone who knows a wee bit about the compilation of eMule in VS. And for those who don't: There still is this thread. Hence, I will not update the src code. :-)
I am an emule-web.de member and fan! Hate me or people will get suspicious about you! Ever wondered if it's all worth the trouble?

Posted Image

No, there will not be a new version of my mods. No, I do not want your PM. No, I am certain, use the board and quit sending PMs. No, I am not kidding, there will not be a new version of my mods just because of YOU asking for it!
0

  • Member Options

Page 1 of 1

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users